summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/arch-chroot/arch-chroot-28.ebuild')
-rw-r--r--sys-apps/arch-chroot/arch-chroot-28.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-apps/arch-chroot/arch-chroot-28.ebuild b/sys-apps/arch-chroot/arch-chroot-28.ebuild
new file mode 100644
index 000000000000..e72e46b48b42
--- /dev/null
+++ b/sys-apps/arch-chroot/arch-chroot-28.ebuild
@@ -0,0 +1,32 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1
+
+DESCRIPTION="Wraps the chroot command while ensuring that important filesystems are mounted"
+HOMEPAGE="https://github.com/archlinux/arch-install-scripts"
+SRC_URI="https://github.com/archlinux/arch-install-scripts/archive/refs/tags/v${PV}.tar.gz -> arch-install-scripts-v${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 arm arm64 hppa ~loong ppc ppc64 ~riscv ~s390 sparc x86"
+
+BDEPEND="app-text/asciidoc"
+
+S="${WORKDIR}/arch-install-scripts-${PV}"
+
+src_compile() {
+ emake MANS="doc/arch-chroot.8" BINPROGS="arch-chroot"
+}
+
+src_test() {
+ emake MANS="doc/arch-chroot.8" BINPROGS="arch-chroot" check
+}
+
+src_install() {
+ dobin arch-chroot
+ doman doc/arch-chroot.8
+ newbashcomp "completion/arch-chroot.bash" "arch-chroot"
+}