summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/attr')
-rw-r--r--sys-apps/attr/Manifest2
-rw-r--r--sys-apps/attr/attr-2.4.48-r4.ebuild92
-rw-r--r--sys-apps/attr/attr-2.4.48-r5.ebuild103
-rw-r--r--sys-apps/attr/attr-2.5.0.ebuild98
-rw-r--r--sys-apps/attr/files/attr-2.4.48-perl-5.26.patch27
-rw-r--r--sys-apps/attr/files/attr-2.4.48-switch-back-to-syscall.patch123
6 files changed, 0 insertions, 445 deletions
diff --git a/sys-apps/attr/Manifest b/sys-apps/attr/Manifest
index c3a9128a6da9..225b7624ecb9 100644
--- a/sys-apps/attr/Manifest
+++ b/sys-apps/attr/Manifest
@@ -1,3 +1 @@
-DIST attr-2.4.48.tar.gz 467840 BLAKE2B 8fa6a5013b927850868b6913d026f23f116b75da3925d5da5eea007e14f5d9e309f98290b7ffaa6c62f620ff8f3ec7bfb3a1fcb04f3c0c072fca5feacaf804c0 SHA512 75f870a0e6e19b8975f3fdceee786fbaff3eadaa9ab9af01996ffa8e50fe5b2bba6e4c22c44a6722d11b55feb9e89895d0151d6811c1d2b475ef4ed145f0c923
-DIST attr-2.5.0.tar.gz 465575 BLAKE2B b50c6b741543140099e7f31fcc327d4547cda41f1b14159664096b571c5c14ed7279992e94fdd9bc23d5618715a7d4fe8d45ba8d5cc2941ac6a4d242bc80ee09 SHA512 900e66d13acd022f52986d4159925b23e60f9ef5d11983b16d9dfe4a98fd70eea5f78e18f3694d8adea1c422324772af4da6b5659d755ed37484b428e28bb5fc
DIST attr-2.5.1.tar.gz 465714 BLAKE2B 05928f8274b0b4beee31b329c8459436c5b9019ebd2f937667b7beb8df7a455c48742a90d9c4faca5c0b38c9c3812043d3d66f9587108d3424c6184fef494b56 SHA512 8b4c043d61f8f3e0cd098e701181069f51117b85fd6ba18bfe9af77d894ea671232377d4793ffc822e9259ceee6ac71d75732eb93b2830c6cb5d0d918ba2d21b
diff --git a/sys-apps/attr/attr-2.4.48-r4.ebuild b/sys-apps/attr/attr-2.4.48-r4.ebuild
deleted file mode 100644
index 02c33f7c1f4f..000000000000
--- a/sys-apps/attr/attr-2.4.48-r4.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic libtool toolchain-funcs multilib-minimal usr-ldscript
-
-DESCRIPTION="Extended attributes tools"
-HOMEPAGE="https://savannah.nongnu.org/projects/attr"
-SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="debug nls static-libs"
-
-BDEPEND="nls? ( sys-devel/gettext )"
-
-PATCHES=(
- "${FILESDIR}/${P}-perl-5.26.patch"
- "${FILESDIR}/${P}-switch-back-to-syscall.patch"
-)
-
-pkg_setup() {
- # Remove -flto* from flags as this breaks binaries (bug #644048)
- filter-flags -flto*
- append-ldflags "-Wl,--no-gc-sections" #700116
-}
-
-src_prepare() {
- default
- elibtoolize #580792
-}
-
-multilib_src_configure() {
- unset PLATFORM #184564
- export OPTIMIZER=${CFLAGS}
- export DEBUG=-DNDEBUG
-
- tc-ld-disable-gold #644048
-
- local myeconfargs=(
- --bindir="${EPREFIX}"/bin
- --enable-shared
- $(use_enable static-libs static)
- $(use_enable nls)
- --libexecdir="${EPREFIX}"/usr/$(get_libdir)
- $(use_enable debug)
- )
- ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
-}
-
-multilib_src_install() {
- emake DESTDIR="${D}" install
-
- # Sanity check until we track down why this is happening. #644048
- local lib="${ED}/usr/$(get_libdir)/libattr.so.1"
- if [[ -e ${lib} ]] ; then
- local versions=$($(tc-getREADELF) -V "${lib}")
- local symbols=$($(tc-getREADELF) -sW "${lib}")
- if [[ "${versions}" != *"ATTR_1.0"* || \
- "${versions}" != *"ATTR_1.1"* || \
- "${versions}" != *"ATTR_1.2"* || \
- "${versions}" != *"ATTR_1.3"* || \
- "${symbols}" != *"getxattr@ATTR_1.0"* ]] ; then
- echo "# readelf -V ${lib}"
- echo "${versions}"
- echo "# readelf -sW ${lib}"
- echo "${symbols}"
- die "symbol version sanity check failed; please comment on https://bugs.gentoo.org/644048"
- else
- einfo "${lib} passed symbol checks"
- fi
- fi
-
- if multilib_is_native_abi; then
- # we install attr into /bin, so we need the shared lib with it
- gen_usr_ldscript -a attr
- fi
-
- # Add a wrapper until people upgrade.
- insinto /usr/include/attr
- newins "${FILESDIR}"/xattr-shim.h xattr.h
-}
-
-multilib_src_install_all() {
- if ! use static-libs; then
- find "${ED}" -name '*.la' -delete || die
- fi
-
- einstalldocs
-}
diff --git a/sys-apps/attr/attr-2.4.48-r5.ebuild b/sys-apps/attr/attr-2.4.48-r5.ebuild
deleted file mode 100644
index 2de4d8189160..000000000000
--- a/sys-apps/attr/attr-2.4.48-r5.ebuild
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-inherit flag-o-matic libtool toolchain-funcs multilib-minimal usr-ldscript
-
-if [[ ${PV} == 9999 ]] ; then
- EGIT_REPO_URI="https://git.savannah.gnu.org/git/${PN}.git"
-
- inherit autotools git-r3
-else
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
- SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
-fi
-
-DESCRIPTION="Extended attributes tools"
-HOMEPAGE="https://savannah.nongnu.org/projects/attr"
-LICENSE="LGPL-2.1"
-SLOT="0"
-
-IUSE="debug nls static-libs"
-
-BDEPEND="nls? ( sys-devel/gettext )"
-
-src_prepare() {
- local PATCHES=(
- "${FILESDIR}/${P}-perl-5.26.patch"
- "${FILESDIR}/${P}-switch-back-to-syscall.patch"
- )
-
- default
-
- if [[ ${PV} == 9999 ]] ; then
- po/update-potfiles || die
- eautopoint
- eautoreconf
- else
- elibtoolize #580792
- fi
-}
-
-src_configure() {
- # Remove -flto* from flags as this breaks binaries (bug #644048)
- filter-flags -flto*
- append-ldflags "-Wl,--no-gc-sections" #700116
- tc-ld-disable-gold #644048
- append-lfs-flags #760857
- multilib-minimal_src_configure
-}
-
-multilib_src_configure() {
- local myeconfargs=(
- --bindir="${EPREFIX}"/bin
- --enable-shared
- $(use_enable static-libs static)
- $(use_enable nls)
- --libexecdir="${EPREFIX}"/usr/$(get_libdir)
- $(use_enable debug)
- )
- ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
-}
-
-multilib_src_install() {
- emake DESTDIR="${D}" install
-
- # Sanity check until we track down why this is happening. #644048
- local lib="${ED}/usr/$(get_libdir)/libattr.so.1"
- if [[ -e ${lib} ]] ; then
- local versions=$($(tc-getREADELF) -V "${lib}")
- local symbols=$($(tc-getREADELF) -sW "${lib}")
- if [[ "${versions}" != *"ATTR_1.0"* || \
- "${versions}" != *"ATTR_1.1"* || \
- "${versions}" != *"ATTR_1.2"* || \
- "${versions}" != *"ATTR_1.3"* || \
- "${symbols}" != *"getxattr@ATTR_1.0"* ]] ; then
- echo "# readelf -V ${lib}"
- echo "${versions}"
- echo "# readelf -sW ${lib}"
- echo "${symbols}"
- die "symbol version sanity check failed; please comment on https://bugs.gentoo.org/644048"
- else
- einfo "${lib} passed symbol checks"
- fi
- fi
-
- if multilib_is_native_abi; then
- # we install attr into /bin, so we need the shared lib with it
- gen_usr_ldscript -a attr
- fi
-
- # Add a wrapper until people upgrade.
- insinto /usr/include/attr
- newins "${FILESDIR}"/xattr-shim.h xattr.h
-}
-
-multilib_src_install_all() {
- if ! use static-libs; then
- find "${ED}" -name '*.la' -delete || die
- fi
-
- einstalldocs
-}
diff --git a/sys-apps/attr/attr-2.5.0.ebuild b/sys-apps/attr/attr-2.5.0.ebuild
deleted file mode 100644
index 7465baca96b8..000000000000
--- a/sys-apps/attr/attr-2.5.0.ebuild
+++ /dev/null
@@ -1,98 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-inherit flag-o-matic libtool toolchain-funcs multilib-minimal usr-ldscript
-
-if [[ ${PV} == 9999 ]] ; then
- EGIT_REPO_URI="https://git.savannah.gnu.org/git/${PN}.git"
-
- inherit autotools git-r3
-else
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
- SRC_URI="mirror://nongnu/${PN}/${P}.tar.gz"
-fi
-
-DESCRIPTION="Extended attributes tools"
-HOMEPAGE="https://savannah.nongnu.org/projects/attr"
-LICENSE="LGPL-2.1"
-SLOT="0"
-
-IUSE="debug nls static-libs"
-
-BDEPEND="nls? ( sys-devel/gettext )"
-
-src_prepare() {
- default
-
- if [[ ${PV} == 9999 ]] ; then
- po/update-potfiles || die
- eautopoint
- eautoreconf
- else
- elibtoolize #580792
- fi
-}
-
-src_configure() {
- # Remove -flto* from flags as this breaks binaries (bug #644048)
- filter-flags -flto*
- append-ldflags "-Wl,--no-gc-sections" #700116
- tc-ld-disable-gold #644048
- append-lfs-flags #760857
- multilib-minimal_src_configure
-}
-
-multilib_src_configure() {
- local myeconfargs=(
- --bindir="${EPREFIX}"/bin
- --enable-shared
- $(use_enable static-libs static)
- $(use_enable nls)
- --libexecdir="${EPREFIX}"/usr/$(get_libdir)
- $(use_enable debug)
- )
- ECONF_SOURCE="${S}" econf "${myeconfargs[@]}"
-}
-
-multilib_src_install() {
- emake DESTDIR="${D}" install
-
- # Sanity check until we track down why this is happening. #644048
- local lib="${ED}/usr/$(get_libdir)/libattr.so.1"
- if [[ -e ${lib} ]] ; then
- local versions=$($(tc-getREADELF) -V "${lib}")
- local symbols=$($(tc-getREADELF) -sW "${lib}")
- if [[ "${versions}" != *"ATTR_1.0"* || \
- "${versions}" != *"ATTR_1.1"* || \
- "${versions}" != *"ATTR_1.2"* || \
- "${versions}" != *"ATTR_1.3"* || \
- "${symbols}" != *"getxattr@ATTR_1.0"* ]] ; then
- echo "# readelf -V ${lib}"
- echo "${versions}"
- echo "# readelf -sW ${lib}"
- echo "${symbols}"
- die "symbol version sanity check failed; please comment on https://bugs.gentoo.org/644048"
- else
- einfo "${lib} passed symbol checks"
- fi
- fi
-
- if multilib_is_native_abi; then
- # we install attr into /bin, so we need the shared lib with it
- gen_usr_ldscript -a attr
- fi
-
- # Add a wrapper until people upgrade.
- insinto /usr/include/attr
- newins "${FILESDIR}"/xattr-shim.h xattr.h
-}
-
-multilib_src_install_all() {
- if ! use static-libs; then
- find "${ED}" -name '*.la' -delete || die
- fi
-
- einstalldocs
-}
diff --git a/sys-apps/attr/files/attr-2.4.48-perl-5.26.patch b/sys-apps/attr/files/attr-2.4.48-perl-5.26.patch
deleted file mode 100644
index 49b4c1a57665..000000000000
--- a/sys-apps/attr/files/attr-2.4.48-perl-5.26.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From 406eab7aa09da9df787a964d3c152c0bda6e23c4 Mon Sep 17 00:00:00 2001
-From: Troy Dawson <tdawson@redhat.com>
-Date: Mon, 24 Jul 2017 14:42:06 +0200
-Subject: [PATCH attr] test: escape left brace in a regex in test/run
-
-... to fix test-suite failure with perl-5.26.0
-
-Bug: https://bugzilla.redhat.com/1473853
----
- test/run | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/test/run b/test/run
-index 4b1f8d0d6134..07e916c41947 100755
---- a/test/run
-+++ b/test/run
-@@ -106,7 +106,7 @@ for (;;) {
- if (defined $line) {
- # Substitute %VAR and %{VAR} with environment variables.
- $line =~ s[%(\w+)][$ENV{$1}]eg;
-- $line =~ s[%{(\w+)}][$ENV{$1}]eg;
-+ $line =~ s[%\{(\w+)}][$ENV{$1}]eg;
- }
- if (defined $line) {
- if ($line =~ s/^\s*< ?//) {
---
-2.16.1
diff --git a/sys-apps/attr/files/attr-2.4.48-switch-back-to-syscall.patch b/sys-apps/attr/files/attr-2.4.48-switch-back-to-syscall.patch
deleted file mode 100644
index 5691b15420ce..000000000000
--- a/sys-apps/attr/files/attr-2.4.48-switch-back-to-syscall.patch
+++ /dev/null
@@ -1,123 +0,0 @@
-From 14adc898a36948267bfe5c63b399996879e94c98 Mon Sep 17 00:00:00 2001
-From: Andreas Gruenbacher <agruenba@redhat.com>
-Date: Fri, 17 Aug 2018 14:07:31 +0200
-Subject: Switch back to syscall()
-
-Switch back to syscall() for the *xattr system calls. The current
-mechanism of forwarding those calls to glibc breaks libraries like
-libfakeroot (fakeroot) and libasan (the gcc address sanitizer; gcc
--fsanitize=address).
-
-Those libraries provide wrappers for functions defined in other shared
-libraries, usually glibc, do their own processing, and forward calls to
-the original symbols looke dup via dlsym(RTLD_NEXT, "symbol_name"). In
-our case, dlsym returns the libattr_*xattr wrappers. However, when our
-wrappers try calling glibc, they end up calling the libfakeroot /
-libasan wrappers instead because those override the original symbols =>
-recursion.
-
-The libattr_*xattr wrappers will only be used when symbols are looked up
-at runtime (dlopen / dlsym). Programs linking against libattr will
-directly use the glibc provided symbols. Therefore, the slightly worse
-performance of syscall() won't affect any of the "normal" users of
-libattr.
----
- libattr/syscalls.c | 26 ++++++++++++++------------
- 1 file changed, 14 insertions(+), 12 deletions(-)
-
-diff --git a/libattr/syscalls.c b/libattr/syscalls.c
-index 3013aa0..721ad7f 100644
---- a/libattr/syscalls.c
-+++ b/libattr/syscalls.c
-@@ -22,6 +22,8 @@
-
- #include "config.h"
-
-+#include <unistd.h>
-+#include <sys/syscall.h>
- #include <sys/xattr.h>
-
- #ifdef HAVE_VISIBILITY_ATTRIBUTE
-@@ -31,67 +33,67 @@
- int libattr_setxattr(const char *path, const char *name,
- void *value, size_t size, int flags)
- {
-- return setxattr(path, name, value, size, flags);
-+ return syscall(__NR_setxattr, path, name, value, size, flags);
- }
-
- int libattr_lsetxattr(const char *path, const char *name,
- void *value, size_t size, int flags)
- {
-- return lsetxattr(path, name, value, size, flags);
-+ return syscall(__NR_lsetxattr, path, name, value, size, flags);
- }
-
- int libattr_fsetxattr(int filedes, const char *name,
- void *value, size_t size, int flags)
- {
-- return fsetxattr(filedes, name, value, size, flags);
-+ return syscall(__NR_fsetxattr, filedes, name, value, size, flags);
- }
-
- ssize_t libattr_getxattr(const char *path, const char *name,
- void *value, size_t size)
- {
-- return getxattr(path, name, value, size);
-+ return syscall(__NR_getxattr, path, name, value, size);
- }
-
- ssize_t libattr_lgetxattr(const char *path, const char *name,
- void *value, size_t size)
- {
-- return lgetxattr(path, name, value, size);
-+ return syscall(__NR_lgetxattr, path, name, value, size);
- }
-
- ssize_t libattr_fgetxattr(int filedes, const char *name,
- void *value, size_t size)
- {
-- return fgetxattr(filedes, name, value, size);
-+ return syscall(__NR_fgetxattr, filedes, name, value, size);
- }
-
- ssize_t libattr_listxattr(const char *path, char *list, size_t size)
- {
-- return listxattr(path, list, size);
-+ return syscall(__NR_listxattr, path, list, size);
- }
-
- ssize_t libattr_llistxattr(const char *path, char *list, size_t size)
- {
-- return llistxattr(path, list, size);
-+ return syscall(__NR_llistxattr, path, list, size);
- }
-
- ssize_t libattr_flistxattr(int filedes, char *list, size_t size)
- {
-- return flistxattr(filedes, list, size);
-+ return syscall(__NR_flistxattr, filedes, list, size);
- }
-
- int libattr_removexattr(const char *path, const char *name)
- {
-- return removexattr(path, name);
-+ return syscall(__NR_removexattr, path, name);
- }
-
- int libattr_lremovexattr(const char *path, const char *name)
- {
-- return lremovexattr(path, name);
-+ return syscall(__NR_lremovexattr, path, name);
- }
-
- int libattr_fremovexattr(int filedes, const char *name)
- {
-- return fremovexattr(filedes, name);
-+ return syscall(__NR_fremovexattr, filedes, name);
- }
-
- #ifdef HAVE_VISIBILITY_ATTRIBUTE
---
-cgit v1.0-41-gc330
-