summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/baobab/baobab-3.26.1.ebuild')
-rw-r--r--sys-apps/baobab/baobab-3.26.1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sys-apps/baobab/baobab-3.26.1.ebuild b/sys-apps/baobab/baobab-3.26.1.ebuild
new file mode 100644
index 000000000000..2b10870a588e
--- /dev/null
+++ b/sys-apps/baobab/baobab-3.26.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2
+
+DESCRIPTION="Disk usage browser for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Baobab"
+
+LICENSE="GPL-2+ FDL-1.1+"
+SLOT="0"
+IUSE=""
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.40:2[dbus]
+ >=x11-libs/gtk+-3.19.1:3
+"
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/gsettings-desktop-schemas
+ x11-themes/adwaita-icon-theme
+ !<gnome-extra/gnome-utils-3.4
+"
+# ${PN} was part of gnome-utils before 3.4
+# libxml2 required for glib-compile-resources
+DEPEND="${COMMON_DEPEND}
+ app-text/yelp-tools
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ VALAC=$(type -P true) \
+ VAPIGEN=$(type -P true)
+}