summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/bolt/bolt-0.8-r1.ebuild')
-rw-r--r--sys-apps/bolt/bolt-0.8-r1.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/sys-apps/bolt/bolt-0.8-r1.ebuild b/sys-apps/bolt/bolt-0.8-r1.ebuild
deleted file mode 100644
index 83ece17b667f..000000000000
--- a/sys-apps/bolt/bolt-0.8-r1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit meson systemd
-
-DESCRIPTION="Userspace system daemon to enable security levels for Thunderbolt 3"
-HOMEPAGE="https://gitlab.freedesktop.org/bolt/bolt"
-SRC_URI="https://gitlab.freedesktop.org/${PN}/${PN}/-/archive/${PV}/${P}.tar.gz
- https://gitlab.freedesktop.org/bolt/bolt/-/commit/5a739574608e5190816b3efd22e75f214c5fe4c4.diff -> ${PN}-210-r2.patch"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc systemd"
-
-DEPEND="
- >=dev-libs/glib-2.50.0:2
- dev-util/glib-utils
- virtual/libudev
- virtual/udev
- dev-util/umockdev
- sys-auth/polkit[introspection]
- systemd? ( sys-apps/systemd )
- doc? ( app-text/asciidoc )"
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- "${DISTDIR}/${PN}-210-r2.patch"
-)
-
-src_configure() {
- local emesonargs=(
- -Dman=$(usex doc true false)
- --sysconfdir=/etc
- --localstatedir=/var
- --sharedstatedir=/var/lib
- )
- meson_src_configure
-}
-
-src_install() {
- meson_src_install
- keepdir /var/lib/boltd
-}