summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/bolt')
-rw-r--r--sys-apps/bolt/Manifest5
-rw-r--r--sys-apps/bolt/bolt-0.9-r1.ebuild52
-rw-r--r--sys-apps/bolt/bolt-0.9.3.ebuild (renamed from sys-apps/bolt/bolt-0.9-r2.ebuild)60
-rw-r--r--sys-apps/bolt/bolt-0.9.6.ebuild71
-rw-r--r--sys-apps/bolt/bolt-0.9.7.ebuild71
-rw-r--r--sys-apps/bolt/bolt-0.9.8-r1.ebuild84
-rw-r--r--sys-apps/bolt/files/bolt.openrc-r114
-rw-r--r--sys-apps/bolt/metadata.xml9
8 files changed, 289 insertions, 77 deletions
diff --git a/sys-apps/bolt/Manifest b/sys-apps/bolt/Manifest
index 41dbe3bd2d07..97d16f04311a 100644
--- a/sys-apps/bolt/Manifest
+++ b/sys-apps/bolt/Manifest
@@ -1 +1,4 @@
-DIST bolt-0.9.tar.gz 238596 BLAKE2B 8032ecb83d39d6c3550c000eed400ee0451e5ed94f7c898ffe9c8fcf512af387cfd759bd94241a47623b5aac63615bcda40ddb3e9ae3ec4060da20e46d7e9b7d SHA512 427e9ad95a8d018dd22326cc4b458fc9149b001d3aa6e4bb8e4047eaf6c3cf04a4dc3be9396049734dc0bd54f990b3bce31b6eef4031e3b671a6202a588cfe78
+DIST bolt-0.9.3.tar.gz 253085 BLAKE2B 7547a35aa16a7681737989c72dfd2e13245eb50c7b814de979974750e3c8805156fd22054308d715299baab3ebd4144923aacc04ef301ee039e84b6370cbcba7 SHA512 2160831011090e75cf54408525f53ead6c0e7797de8a4afdd07ef5a035f8e1aa58f34efb9bd52e6e7cd93ac17751e72ff27e99f2b372a5720b2cbadd6abb3c26
+DIST bolt-0.9.6.tar.bz2 192324 BLAKE2B 88e5b94e75833bb5cef090650158ffd26e642188e876cf54407fee7535498faa7ff138b7d47911ea85cacf2bb6ac778b32c23d5cd942c27d1edacc395ec6c9a3 SHA512 7a72b17dbb02917fd55cc480bc4c3ec948577b61aab2ffb366608e82ca65add4e7b402c3b89fd3f98f660165b335ebc9564444bbae3ab55bd6a63c4e0019266a
+DIST bolt-0.9.7.tar.gz 255976 BLAKE2B c7764cb1334f2df96856cb9a92fe6c0ba97ed81340690537fe4567f81bbbf1ee4fbfc659c8b43716f6756d53ab21c71a5c8c9952aea19d1c3f0c14386d327331 SHA512 a9ae0425cdba8932356ec4dcf3f6b3469478c01d47ef3b741c0a841117c81b354f35860be6011ea3b43b28ae10164909a82e2bdbcf92e8541c637cf44277a36c
+DIST bolt-0.9.8.tar.bz2 192836 BLAKE2B 7a06572562af5586d479fee58fb2469b8d804d6eafb41a52c5a575ef2acf616fb684b4e92181430444d67d9889c836bd6d96e1a6d3460cd01300f80d99876c04 SHA512 e9b2ccca66930ee40fd283b09e4bd2bffe1f496e4f898a9d4e069e673a2c9320d456b9ad4b33c4e3e26d25f363985a798c6c860c4c0b103558dbbab78f02ba2b
diff --git a/sys-apps/bolt/bolt-0.9-r1.ebuild b/sys-apps/bolt/bolt-0.9-r1.ebuild
deleted file mode 100644
index afb1c1ec6aad..000000000000
--- a/sys-apps/bolt/bolt-0.9-r1.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit linux-info meson systemd
-
-DESCRIPTION="Userspace system daemon to enable security levels for Thunderbolt 3"
-HOMEPAGE="https://gitlab.freedesktop.org/bolt/bolt"
-SRC_URI="https://gitlab.freedesktop.org/${PN}/${PN}/-/archive/${PV}/${P}.tar.gz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc systemd"
-
-DEPEND="
- >=dev-libs/glib-2.56.0:2
- dev-util/glib-utils
- virtual/libudev
- virtual/udev
- dev-util/umockdev
- sys-auth/polkit[introspection]
- systemd? ( sys-apps/systemd )
- doc? ( app-text/asciidoc )"
-RDEPEND="${DEPEND}"
-
-pkg_pretend() {
- CONFIG_CHECK="~THUNDERBOLT"
- ERROR_THUNDERBOLT="This package requires the thunderbolt kernel driver."
- check_extra_config
-
- CONFIG_CHECK="~HOTPLUG_PCI"
- ERROR_HOTPLUG_PCI="Thunderbolt requires PCI hotplug support."
- check_extra_config
-}
-
-src_configure() {
- local emesonargs=(
- -Dman=$(usex doc true false)
- --sysconfdir=/etc
- --localstatedir=/var
- --sharedstatedir=/var/lib
- )
- meson_src_configure
-}
-
-src_install() {
- meson_src_install
- newinitd "${FILESDIR}"/${PN}.openrc boltd
- keepdir /var/lib/boltd
-}
diff --git a/sys-apps/bolt/bolt-0.9-r2.ebuild b/sys-apps/bolt/bolt-0.9.3.ebuild
index ddf044ade359..16e2be81e05b 100644
--- a/sys-apps/bolt/bolt-0.9-r2.ebuild
+++ b/sys-apps/bolt/bolt-0.9.3.ebuild
@@ -1,31 +1,38 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit linux-info meson systemd
+inherit linux-info meson udev
DESCRIPTION="Userspace system daemon to enable security levels for Thunderbolt 3"
HOMEPAGE="https://gitlab.freedesktop.org/bolt/bolt"
SRC_URI="https://gitlab.freedesktop.org/${PN}/${PN}/-/archive/${PV}/${P}.tar.gz"
-LICENSE="LGPL-2.1"
+LICENSE="LGPL-2.1 GPL-2+"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc systemd"
+KEYWORDS="amd64 ~loong ~riscv x86"
+IUSE="selinux test"
+RESTRICT="!test? ( test )"
-DEPEND="
+RDEPEND="
>=dev-libs/glib-2.56.0:2
- dev-util/glib-utils
- virtual/libudev
+ virtual/libudev:=
virtual/udev
- dev-util/umockdev
sys-auth/polkit[introspection]
- systemd? ( sys-apps/systemd )
- doc? ( app-text/asciidoc )"
-RDEPEND="${DEPEND}"
+ selinux? ( sec-policy/selinux-thunderbolt )
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-util/umockdev )
+"
+BDEPEND="
+ app-text/asciidoc
+ dev-util/glib-utils
+ virtual/pkgconfig
+"
-pkg_pretend() {
+pkg_setup() {
if use kernel_linux && kernel_is lt 5 6; then
CONFIG_CHECK="~THUNDERBOLT"
ERROR_THUNDERBOLT="This package requires the thunderbolt kernel driver."
@@ -33,25 +40,32 @@ pkg_pretend() {
CONFIG_CHECK="~USB4"
ERROR_USB4="This package requires the USB4 kernel driver for Thunderbolt support."
fi
- check_extra_config
-
- CONFIG_CHECK="~HOTPLUG_PCI"
+ CONFIG_CHECK+=" ~HOTPLUG_PCI"
ERROR_HOTPLUG_PCI="Thunderbolt requires PCI hotplug support."
- check_extra_config
+
+ linux-info_pkg_setup
}
src_configure() {
local emesonargs=(
- -Dman=$(usex doc true false)
- --sysconfdir=/etc
- --localstatedir=/var
- --sharedstatedir=/var/lib
+ -Dman=true
+ --sysconfdir="${EPREFIX}"/etc
+ --localstatedir="${EPREFIX}"/var
+ --sharedstatedir="${EPREFIX}"/var/lib
)
meson_src_configure
}
src_install() {
meson_src_install
- newinitd "${FILESDIR}"/${PN}.openrc boltd
+ newinitd "${FILESDIR}"/${PN}.openrc-r1 boltd
keepdir /var/lib/boltd
}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}
diff --git a/sys-apps/bolt/bolt-0.9.6.ebuild b/sys-apps/bolt/bolt-0.9.6.ebuild
new file mode 100644
index 000000000000..eceef5e6be77
--- /dev/null
+++ b/sys-apps/bolt/bolt-0.9.6.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info meson udev
+
+DESCRIPTION="Userspace system daemon to enable security levels for Thunderbolt 3"
+HOMEPAGE="https://gitlab.freedesktop.org/bolt/bolt"
+SRC_URI="https://gitlab.freedesktop.org/${PN}/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1 GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~riscv ~x86"
+IUSE="selinux test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.56.0:2
+ virtual/libudev:=
+ virtual/udev
+ sys-auth/polkit[introspection]
+ selinux? ( sec-policy/selinux-thunderbolt )
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-util/umockdev )
+"
+BDEPEND="
+ app-text/asciidoc
+ dev-util/glib-utils
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ if use kernel_linux && kernel_is lt 5 6; then
+ CONFIG_CHECK="~THUNDERBOLT"
+ ERROR_THUNDERBOLT="This package requires the thunderbolt kernel driver."
+ else
+ CONFIG_CHECK="~USB4"
+ ERROR_USB4="This package requires the USB4 kernel driver for Thunderbolt support."
+ fi
+ CONFIG_CHECK+=" ~HOTPLUG_PCI"
+ ERROR_HOTPLUG_PCI="Thunderbolt requires PCI hotplug support."
+
+ linux-info_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dman=true
+ --sysconfdir="${EPREFIX}"/etc
+ --localstatedir="${EPREFIX}"/var
+ --sharedstatedir="${EPREFIX}"/var/lib
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ newinitd "${FILESDIR}"/${PN}.openrc-r1 boltd
+ keepdir /var/lib/boltd
+}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}
diff --git a/sys-apps/bolt/bolt-0.9.7.ebuild b/sys-apps/bolt/bolt-0.9.7.ebuild
new file mode 100644
index 000000000000..3fc4a5615f8e
--- /dev/null
+++ b/sys-apps/bolt/bolt-0.9.7.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info meson udev
+
+DESCRIPTION="Userspace system daemon to enable security levels for Thunderbolt 3"
+HOMEPAGE="https://gitlab.freedesktop.org/bolt/bolt"
+SRC_URI="https://gitlab.freedesktop.org/${PN}/${PN}/-/archive/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1 GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~riscv ~x86"
+IUSE="selinux test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.56.0:2
+ virtual/libudev:=
+ virtual/udev
+ sys-auth/polkit[introspection]
+ selinux? ( sec-policy/selinux-thunderbolt )
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-util/umockdev )
+"
+BDEPEND="
+ app-text/asciidoc
+ dev-util/glib-utils
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ if use kernel_linux && kernel_is lt 5 6; then
+ CONFIG_CHECK="~THUNDERBOLT"
+ ERROR_THUNDERBOLT="This package requires the thunderbolt kernel driver."
+ else
+ CONFIG_CHECK="~USB4"
+ ERROR_USB4="This package requires the USB4 kernel driver for Thunderbolt support."
+ fi
+ CONFIG_CHECK+=" ~HOTPLUG_PCI"
+ ERROR_HOTPLUG_PCI="Thunderbolt requires PCI hotplug support."
+
+ linux-info_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dman=true
+ --sysconfdir="${EPREFIX}"/etc
+ --localstatedir="${EPREFIX}"/var
+ --sharedstatedir="${EPREFIX}"/var/lib
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ newinitd "${FILESDIR}"/${PN}.openrc-r1 boltd
+ keepdir /var/lib/boltd
+}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}
diff --git a/sys-apps/bolt/bolt-0.9.8-r1.ebuild b/sys-apps/bolt/bolt-0.9.8-r1.ebuild
new file mode 100644
index 000000000000..bad401eb2907
--- /dev/null
+++ b/sys-apps/bolt/bolt-0.9.8-r1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_1{0..2} )
+inherit linux-info python-any-r1 meson udev
+
+DESCRIPTION="Userspace system daemon to enable security levels for Thunderbolt 3"
+HOMEPAGE="https://gitlab.freedesktop.org/bolt/bolt"
+SRC_URI="https://gitlab.freedesktop.org/${PN}/${PN}/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1 GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~loong ~riscv ~x86"
+IUSE="selinux test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/glib-2.56.0:2
+ virtual/libudev:=
+ virtual/udev
+ sys-auth/polkit[introspection]
+ selinux? ( sec-policy/selinux-thunderbolt )
+"
+DEPEND="
+ ${RDEPEND}
+ test? (
+ dev-util/umockdev
+ )
+"
+BDEPEND="
+ app-text/asciidoc
+ dev-util/glib-utils
+ virtual/pkgconfig
+ test? (
+ dev-util/umockdev
+ ${PYTHON_DEPS}
+ $(python_gen_any_dep \
+ 'dev-python/pygobject[${PYTHON_USEDEP}]' \
+ 'dev-python/dbus-python[${PYTHON_USEDEP}]' \
+ 'dev-python/python-dbusmock[${PYTHON_USEDEP}]'
+ )
+ )
+"
+
+pkg_setup() {
+ if use kernel_linux && kernel_is lt 5 6; then
+ CONFIG_CHECK="~THUNDERBOLT"
+ ERROR_THUNDERBOLT="This package requires the thunderbolt kernel driver."
+ else
+ CONFIG_CHECK="~USB4"
+ ERROR_USB4="This package requires the USB4 kernel driver for Thunderbolt support."
+ fi
+ CONFIG_CHECK+=" ~HOTPLUG_PCI"
+ ERROR_HOTPLUG_PCI="Thunderbolt requires PCI hotplug support."
+
+ linux-info_pkg_setup
+ python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dman=true
+ --sysconfdir="${EPREFIX}"/etc
+ --localstatedir="${EPREFIX}"/var
+ --sharedstatedir="${EPREFIX}"/var/lib
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ newinitd "${FILESDIR}"/${PN}.openrc-r1 boltd
+ keepdir /var/lib/boltd
+}
+
+pkg_postinst() {
+ udev_reload
+}
+
+pkg_postrm() {
+ udev_reload
+}
diff --git a/sys-apps/bolt/files/bolt.openrc-r1 b/sys-apps/bolt/files/bolt.openrc-r1
new file mode 100644
index 000000000000..f47b15ffaecb
--- /dev/null
+++ b/sys-apps/bolt/files/bolt.openrc-r1
@@ -0,0 +1,14 @@
+#!/sbin/openrc-run
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+name="Thunderbolt Security Daemon"
+description="Userspace system daemon to enable security levels for Thunderbolt 3"
+command="/usr/libexec/boltd"
+command_background="true"
+pidfile="/var/run/boltd.pid"
+
+depend() {
+ need dbus
+ before display-manager
+}
diff --git a/sys-apps/bolt/metadata.xml b/sys-apps/bolt/metadata.xml
index 3ffdeb4af3b5..326932801a6a 100644
--- a/sys-apps/bolt/metadata.xml
+++ b/sys-apps/bolt/metadata.xml
@@ -1,8 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="person">
<email>prometheanfire@gentoo.org</email>
<name>Matthew Thode</name>
</maintainer>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="freedesktop-gitlab">bolt/bolt</remote-id>
+ </upstream>
</pkgmetadata>