summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/busybox/busybox-1.28.3.ebuild')
-rw-r--r--sys-apps/busybox/busybox-1.28.3.ebuild15
1 files changed, 10 insertions, 5 deletions
diff --git a/sys-apps/busybox/busybox-1.28.3.ebuild b/sys-apps/busybox/busybox-1.28.3.ebuild
index 68000bffa174..f28bf04dfd72 100644
--- a/sys-apps/busybox/busybox-1.28.3.ebuild
+++ b/sys-apps/busybox/busybox-1.28.3.ebuild
@@ -3,8 +3,9 @@
# See `man savedconfig.eclass` for info on how to use USE=savedconfig.
-EAPI="5"
-inherit eutils flag-o-matic savedconfig toolchain-funcs multilib
+EAPI=6
+
+inherit flag-o-matic savedconfig toolchain-funcs
DESCRIPTION="Utilities for rescue and embedded systems"
HOMEPAGE="https://www.busybox.net/"
@@ -62,14 +63,18 @@ busybox_config_enabled() {
esac
}
+# patches go here!
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.26.2-bb.patch
+ # "${FILESDIR}"/${P}-*.patch
+)
+
src_prepare() {
+ default
unset KBUILD_OUTPUT #88088
append-flags -fno-strict-aliasing #310413
use ppc64 && append-flags -mminimal-toc #130943
- # patches go here!
- epatch "${FILESDIR}"/${PN}-1.26.2-bb.patch
-# epatch "${FILESDIR}"/${P}-*.patch
cp "${FILESDIR}"/ginit.c init/ || die
# flag cleanup