summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/checkpolicy/checkpolicy-3.1.ebuild')
-rw-r--r--sys-apps/checkpolicy/checkpolicy-3.1.ebuild57
1 files changed, 0 insertions, 57 deletions
diff --git a/sys-apps/checkpolicy/checkpolicy-3.1.ebuild b/sys-apps/checkpolicy/checkpolicy-3.1.ebuild
deleted file mode 100644
index 1b8381709ac8..000000000000
--- a/sys-apps/checkpolicy/checkpolicy-3.1.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="7"
-
-inherit toolchain-funcs
-
-MY_P="${P//_/-}"
-MY_RELEASEDATE="20200710"
-
-SEPOL_VER="${PV}"
-SEMNG_VER="${PV}"
-
-DESCRIPTION="SELinux policy compiler"
-HOMEPAGE="http://userspace.selinuxproject.org"
-
-if [[ ${PV} == 9999 ]] ; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/SELinuxProject/selinux.git"
- S="${WORKDIR}/${MY_P}/${PN}"
-else
- SRC_URI="https://github.com/SELinuxProject/selinux/releases/download/${MY_RELEASEDATE}/${MY_P}.tar.gz"
- KEYWORDS="amd64 ~arm ~arm64 ~mips x86"
- S="${WORKDIR}/${MY_P}"
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="debug"
-
-DEPEND=">=sys-libs/libsepol-${SEPOL_VER}"
-BDEPEND="sys-devel/flex
- sys-devel/bison"
-
-RDEPEND=">=sys-libs/libsepol-${SEPOL_VER}"
-
-src_compile() {
- emake \
- CC="$(tc-getCC)" \
- YACC="bison -y" \
- LIBDIR="\$(PREFIX)/$(get_libdir)"
-}
-
-src_install() {
- default
-
- if use debug; then
- dobin "${S}/test/dismod"
- dobin "${S}/test/dispol"
- fi
-}
-
-pkg_postinst() {
- if ! tc-is-cross-compiler; then
- einfo "This checkpolicy can compile version `checkpolicy -V | cut -f 1 -d ' '` policy."
- fi
-}