summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/cpint/cpint-2.5.3.ebuild')
-rw-r--r--sys-apps/cpint/cpint-2.5.3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sys-apps/cpint/cpint-2.5.3.ebuild b/sys-apps/cpint/cpint-2.5.3.ebuild
new file mode 100644
index 000000000000..4156ebe6da24
--- /dev/null
+++ b/sys-apps/cpint/cpint-2.5.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit linux-info eutils
+
+MY_PV=${PV//./}
+
+DESCRIPTION="Linux/390 Interface to z/VM's Control Program"
+HOMEPAGE="http://linuxvm.org/Patches/index.html"
+SRC_URI="http://linuxvm.org/Patches/s390/${PN}${MY_PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="s390"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+ epatch "${FILESDIR}"/${P}-prototypes.patch
+ epatch "${FILESDIR}"/${P}-kernel.patch
+
+ # the makefile uses this variable
+ export KERNEL_DIR
+}
+
+src_install() {
+ emake install prefix="${D}"
+ dodoc ChangeLog HOW-TO
+}