summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/dchroot/dchroot-0.12.1.ebuild')
-rw-r--r--sys-apps/dchroot/dchroot-0.12.1.ebuild14
1 files changed, 5 insertions, 9 deletions
diff --git a/sys-apps/dchroot/dchroot-0.12.1.ebuild b/sys-apps/dchroot/dchroot-0.12.1.ebuild
index 6caede8eede4..eee10e8bef06 100644
--- a/sys-apps/dchroot/dchroot-0.12.1.ebuild
+++ b/sys-apps/dchroot/dchroot-0.12.1.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="2"
+EAPI=6
inherit toolchain-funcs
DESCRIPTION="Utility for managing chroots for non-root users"
-HOMEPAGE="http://packages.debian.org/unstable/admin/dchroot"
+HOMEPAGE="https://packages.debian.org/unstable/admin/dchroot"
SRC_URI="mirror://debian/pool/main/d/dchroot/dchroot_${PV}.tar.gz"
LICENSE="GPL-2"
@@ -18,6 +18,7 @@ DEPEND="sys-apps/help2man"
RDEPEND="!dev-util/schroot[dchroot]"
src_prepare() {
+ default
sed -i \
-e '/^all:/s:$: docs:' \
-e '/^CFLAGS/s:-O2:@CFLAGS@:' \
@@ -26,10 +27,5 @@ src_prepare() {
}
src_compile() {
- emake CC="$(tc-getCC)" || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc README TODO
+ emake CC="$(tc-getCC)"
}