summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/diffutils/diffutils-3.6-r1.ebuild')
-rw-r--r--sys-apps/diffutils/diffutils-3.6-r1.ebuild44
1 files changed, 0 insertions, 44 deletions
diff --git a/sys-apps/diffutils/diffutils-3.6-r1.ebuild b/sys-apps/diffutils/diffutils-3.6-r1.ebuild
deleted file mode 100644
index ad6055ecdcc8..000000000000
--- a/sys-apps/diffutils/diffutils-3.6-r1.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit flag-o-matic
-
-DESCRIPTION="Tools to make diffs and compare files"
-HOMEPAGE="https://www.gnu.org/software/diffutils/"
-SRC_URI="mirror://gnu/diffutils/${P}.tar.xz
- mirror://gnu-alpha/diffutils/${P}.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv s390 sparc x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="nls static"
-
-DEPEND="app-arch/xz-utils
- nls? ( sys-devel/gettext )"
-
-DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
-
-src_configure() {
- use static && append-ldflags -static
-
- # Disable automagic dependency over libsigsegv; see bug #312351.
- export ac_cv_libsigsegv=no
-
- # required for >=glibc-2.26, bug #653914
- use elibc_glibc && export gl_cv_func_getopt_gnu=yes
-
- local myeconfargs=(
- --with-packager="Gentoo"
- --with-packager-version="${PVR}"
- --with-packager-bug-reports="https://bugs.gentoo.org/"
- $(use_enable nls)
- )
- econf "${myeconfargs[@]}"
-}
-
-src_test() {
- # explicitly allow parallel testing
- emake check
-}