summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/edac-utils/edac-utils-0.18.ebuild')
-rw-r--r--sys-apps/edac-utils/edac-utils-0.18.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/sys-apps/edac-utils/edac-utils-0.18.ebuild b/sys-apps/edac-utils/edac-utils-0.18.ebuild
deleted file mode 100644
index 86bafa9ff0dc..000000000000
--- a/sys-apps/edac-utils/edac-utils-0.18.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-DESCRIPTION="Userspace helper for Linux kernel EDAC drivers"
-HOMEPAGE="https://github.com/grondo/edac-utils"
-SRC_URI="https://github.com/grondo/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ~arm64"
-IUSE="debug"
-
-DEPEND="sys-fs/sysfsutils"
-RDEPEND="${DEPEND}
- sys-apps/dmidecode"
-
-src_prepare() {
- sed -i \
- -e 's|-Werror||' \
- configure || die
-}
-
-src_configure() {
- econf \
- --disable-static \
- $(use_enable debug)
-}
-
-src_install() {
- default
-
- # We don't need this init.d file
- # Modules should be loaded by adding them to /etc/conf.d/modules
- # The rest is done via the udev-rule
- rm -rf "${D}/etc/init.d"
-
- find "${ED}" -name '*.la' -delete || die
-}
-
-pkg_postinst() {
- elog "There must be an entry for your mainboard in /etc/edac/labels.db"
- elog "in case you want nice labels in /sys/module/*_edac/"
- elog "Run the following command to check whether such an entry is already available:"
- elog " edac-ctl --print-labels"
-}