summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/firejail/firejail-9999.ebuild')
-rw-r--r--sys-apps/firejail/firejail-9999.ebuild65
1 files changed, 41 insertions, 24 deletions
diff --git a/sys-apps/firejail/firejail-9999.ebuild b/sys-apps/firejail/firejail-9999.ebuild
index 8dfef8571888..5858a542c311 100644
--- a/sys-apps/firejail/firejail-9999.ebuild
+++ b/sys-apps/firejail/firejail-9999.ebuild
@@ -3,9 +3,13 @@
EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit toolchain-funcs python-single-r1 linux-info
+
if [[ ${PV} != 9999 ]]; then
KEYWORDS="~amd64 ~x86"
- SRC_URI="https://github.com/netblue30/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ SRC_URI="https://github.com/netblue30/${PN}/releases/download/${PV}/${P}.tar.xz"
else
inherit git-r3
EGIT_REPO_URI="https://github.com/netblue30/firejail.git"
@@ -17,32 +21,37 @@ HOMEPAGE="https://firejail.wordpress.com/"
LICENSE="GPL-2"
SLOT="0"
-IUSE="apparmor +chroot contrib debug +file-transfer +globalcfg +network +overlayfs +private-home +seccomp +suid test +userns vim-syntax +whitelist x11"
+IUSE="X apparmor +chroot contrib +dbusproxy +file-transfer +globalcfg +network +overlayfs +private-home +suid test +userns +whitelist"
+RESTRICT="!test? ( test )"
-DEPEND="!sys-apps/firejail-lts
+RDEPEND="!sys-apps/firejail-lts
apparmor? ( sys-libs/libapparmor )
+ contrib? ( ${PYTHON_DEPS} )
+ dbusproxy? ( sys-apps/xdg-dbus-proxy )"
+
+DEPEND="${RDEPEND}
+ sys-libs/libseccomp
test? ( dev-tcltk/expect )"
-RDEPEND="apparmor? ( sys-libs/libapparmor )"
+REQUIRED_USE="contrib? ( ${PYTHON_REQUIRED_USE} )"
-# TODO: enable tests
-RESTRICT="test"
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
src_prepare() {
default
- find ./contrib -type f -name '*.py' | xargs sed --in-place 's-#!/usr/bin/python3-#!/usr/bin/env python3-g' || die
-
- find -type f -name Makefile.in | xargs sed --in-place --regexp-extended \
- --expression='/^\tinstall .*COPYING /d' \
- --expression='/CFLAGS/s: (-O2|-ggdb) : :g' || die
+ find -type f -name Makefile.in -exec sed -i -r -e '/^\tinstall .*COPYING /d; /CFLAGS/s: (-O2|-ggdb) : :g' {} + || die
- sed --in-place --regexp-extended '/CFLAGS/s: (-O2|-ggdb) : :g' ./src/common.mk.in || die
+ sed -i -r -e '/CFLAGS/s: (-O2|-ggdb) : :g' ./src/common.mk.in || die
# remove compression of man pages
- sed --in-place '/gzip -9n $$man; \\/d' Makefile.in || die
- sed --in-place '/rm -f $$man.gz; \\/d' Makefile.in || die
- sed --in-place --regexp-extended 's|\*\.([[:digit:]])\) install -c -m 0644 \$\$man\.gz|\*\.\1\) install -c -m 0644 \$\$man|g' Makefile.in || die
+ sed -i -r -e '/rm -f \$\$man.gz; \\/d; /gzip -9n \$\$man; \\/d; s|\*\.([[:digit:]])\) install -m 0644 \$\$man\.gz|\*\.\1\) install -m 0644 \$\$man|g' Makefile.in || die
+
+ if use contrib; then
+ python_fix_shebang -f contrib/*.py
+ fi
}
src_configure() {
@@ -50,27 +59,35 @@ src_configure() {
--disable-firetunnel \
$(use_enable apparmor) \
$(use_enable chroot) \
- $(use_enable contrib contrib-install) \
+ $(use_enable dbusproxy) \
$(use_enable file-transfer) \
$(use_enable globalcfg) \
$(use_enable network) \
$(use_enable overlayfs) \
$(use_enable private-home) \
- $(use_enable seccomp) \
$(use_enable suid) \
$(use_enable userns) \
$(use_enable whitelist) \
- $(use_enable x11)
+ $(use_enable X x11)
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
}
src_install() {
default
- if use vim-syntax; then
- insinto /usr/share/vim/vimfiles/ftdetect
- doins contrib/vim/ftdetect/firejail.vim
-
- insinto /usr/share/vim/vimfiles/syntax
- doins contrib/vim/syntax/firejail.vim
+ if use contrib; then
+ python_scriptinto /usr/$(get_libdir)/firejail
+ python_doscript contrib/*.py
+ insinto /usr/$(get_libdir)/firejail
+ dobin contrib/*.sh
fi
}
+
+pkg_postinst() {
+ CONFIG_CHECK="~SQUASHFS"
+ local ERROR_SQUASHFS="CONFIG_SQUASHFS: required for firejail --appimage mode"
+ check_extra_config
+}