summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/fwupdate/fwupdate-10.ebuild')
-rw-r--r--sys-apps/fwupdate/fwupdate-10.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/sys-apps/fwupdate/fwupdate-10.ebuild b/sys-apps/fwupdate/fwupdate-10.ebuild
deleted file mode 100644
index e568ed34d907..000000000000
--- a/sys-apps/fwupdate/fwupdate-10.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit mount-boot toolchain-funcs
-
-DESCRIPTION="Tools for using the ESRT and UpdateCapsule() to apply firmware updates"
-HOMEPAGE="https://github.com/rhinstaller/fwupdate"
-SRC_URI="https://github.com/rhinstaller/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="
- dev-libs/popt
- >=sys-libs/efivar-32-r1
- >=sys-libs/libsmbios-2.3.3
-"
-DEPEND="
- ${RDEPEND}
- sys-boot/gnu-efi
-"
-
-do_make() {
- emake \
- CC="$(tc-getCC)" \
- EFIDIR="gentoo" \
- GNUEFIDIR="/usr/$(get_libdir)" \
- "${@}"
-}
-
-src_prepare() {
- default
-
- # Remove -Werror
- sed 's@ -Werror\([[:space:]]\|\n\)@\1@' -i linux/Makefile || die
-}
-
-src_compile() {
- do_make
-}
-
-src_install() {
- do_make DESTDIR="${D}" install
-}