summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/groff/groff-1.22.2.ebuild')
-rw-r--r--sys-apps/groff/groff-1.22.2.ebuild9
1 files changed, 6 insertions, 3 deletions
diff --git a/sys-apps/groff/groff-1.22.2.ebuild b/sys-apps/groff/groff-1.22.2.ebuild
index e731d95545ce..de668f383538 100644
--- a/sys-apps/groff/groff-1.22.2.ebuild
+++ b/sys-apps/groff/groff-1.22.2.ebuild
@@ -84,9 +84,12 @@ src_install() {
dosym tbl /usr/bin/gtbl
if ! use examples ; then
- # Keep mom-pdf.pdf since it's more of a manual than an example. #454196 #516732
- rm -f "${ED}"/usr/share/doc/${PF}/pdf/mom-pdf.pdf
- mv "${ED}"/usr/share/doc/${PF}/{examples/mom,pdf}/mom-pdf.pdf || die
+ # The pdf files might not be generated if ghostscript is unavailable. #602020
+ local pdf="${ED}/usr/share/doc/${PF}/examples/mom/mom-pdf.pdf"
+ if [[ -e ${pdf} ]] ; then
+ # Keep mom-pdf.pdf since it's more of a manual than an example. #454196 #516732
+ mv "${pdf}" "${ED}"/usr/share/doc/${PF}/pdf/ || die
+ fi
rm -rf "${ED}"/usr/share/doc/${PF}/examples
fi
}