summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/hwloc/hwloc-2.9.3-r1.ebuild')
-rw-r--r--sys-apps/hwloc/hwloc-2.9.3-r1.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/sys-apps/hwloc/hwloc-2.9.3-r1.ebuild b/sys-apps/hwloc/hwloc-2.9.3-r1.ebuild
index 4d0252d24ecc..84c0ef23b8f9 100644
--- a/sys-apps/hwloc/hwloc-2.9.3-r1.ebuild
+++ b/sys-apps/hwloc/hwloc-2.9.3-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-inherit autotools bash-completion-r1 cuda desktop flag-o-matic systemd toolchain-funcs multilib-minimal
+inherit autotools bash-completion-r1 cuda desktop flag-o-matic systemd toolchain-funcs xdg-utils multilib-minimal
MY_PV="v$(ver_cut 1-2)"
DESCRIPTION="Displays the hardware topology in convenient formats"
@@ -127,3 +127,11 @@ multilib_src_install_all() {
find "${ED}" -name '*.la' -delete || die
newicon -s 512 "${DISTDIR}/lstopo.png" ${PN}.png
}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}