summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/iproute2/iproute2-4.15.0.ebuild')
-rw-r--r--sys-apps/iproute2/iproute2-4.15.0.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/sys-apps/iproute2/iproute2-4.15.0.ebuild b/sys-apps/iproute2/iproute2-4.15.0.ebuild
index f38e3db1ff8f..15efa9acf6c9 100644
--- a/sys-apps/iproute2/iproute2-4.15.0.ebuild
+++ b/sys-apps/iproute2/iproute2-4.15.0.ebuild
@@ -18,12 +18,13 @@ HOMEPAGE="https://wiki.linuxfoundation.org/networking/iproute2"
LICENSE="GPL-2"
SLOT="0"
-IUSE="atm berkdb +iptables ipv6 minimal selinux"
+IUSE="atm berkdb elf +iptables ipv6 minimal selinux"
# We could make libmnl optional, but it's tiny, so eh
RDEPEND="
!net-misc/arpd
- !minimal? ( net-libs/libmnl virtual/libelf )
+ !minimal? ( net-libs/libmnl )
+ elf? ( virtual/libelf )
iptables? ( >=net-firewall/iptables-1.4.20:= )
berkdb? ( sys-libs/db:= )
atm? ( net-dialup/linux-atm )
@@ -101,7 +102,7 @@ src_configure() {
TC_CONFIG_IPSET := y
HAVE_BERKELEY_DB := $(usex berkdb y n)
HAVE_MNL := $(usex minimal n y)
- HAVE_ELF := $(usex minimal n y)
+ HAVE_ELF := $(usex elf y n)
HAVE_SELINUX := $(usex selinux y n)
IP_CONFIG_SETNS := ${setns}
# Use correct iptables dir, #144265 #293709