summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/kexec-tools/kexec-tools-2.0.22.ebuild')
-rw-r--r--sys-apps/kexec-tools/kexec-tools-2.0.22.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/sys-apps/kexec-tools/kexec-tools-2.0.22.ebuild b/sys-apps/kexec-tools/kexec-tools-2.0.22.ebuild
index c92e41d36170..2f8eea8c0dee 100644
--- a/sys-apps/kexec-tools/kexec-tools-2.0.22.ebuild
+++ b/sys-apps/kexec-tools/kexec-tools-2.0.22.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit libtool linux-info systemd
+inherit libtool linux-info optfeature systemd
if [[ ${PV} == "9999" ]] ; then
inherit git-r3 autotools
@@ -121,4 +121,7 @@ pkg_postinst() {
ewarn "in case running system and initramfs do not agree on detected"
ewarn "root device name!"
fi
+
+ optfeature "automatically updating /etc/kexec.conf on each kernel installation" \
+ "sys-kernel/installkernel[-systemd]"
}