summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/logwatch/logwatch-7.4.2.ebuild')
-rw-r--r--sys-apps/logwatch/logwatch-7.4.2.ebuild85
1 files changed, 85 insertions, 0 deletions
diff --git a/sys-apps/logwatch/logwatch-7.4.2.ebuild b/sys-apps/logwatch/logwatch-7.4.2.ebuild
new file mode 100644
index 000000000000..9618d77b447c
--- /dev/null
+++ b/sys-apps/logwatch/logwatch-7.4.2.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Analyzes and Reports on system logs"
+HOMEPAGE="http://www.logwatch.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND="virtual/cron
+ virtual/mta
+ virtual/mailx
+ dev-lang/perl
+ dev-perl/Date-Calc
+ dev-perl/DateManip
+ dev-perl/Tie-IxHash
+ dev-perl/Sys-CPU
+ dev-perl/Sys-MemInfo"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-7.4.2-openssh-hpn.patch
+}
+
+src_install() {
+ dodir /usr/share/logwatch/lib
+ dodir /usr/share/logwatch/scripts/services
+ dodir /usr/share/logwatch/scripts/shared
+ dodir /usr/share/logwatch/default.conf/logfiles
+ dodir /usr/share/logwatch/default.conf/services
+ dodir /usr/share/logwatch/default.conf/html
+ keepdir /etc/logwatch
+
+ newsbin scripts/logwatch.pl logwatch.pl
+
+ exeinto /usr/share/logwatch/lib
+ doexe lib/*.pm
+
+ exeinto /usr/share/logwatch/scripts/services
+ doexe scripts/services/*
+
+ exeinto /usr/share/logwatch/scripts/shared
+ doexe scripts/shared/*
+
+ insinto /usr/share/logwatch/default.conf
+ doins conf/logwatch.conf
+
+ insinto /usr/share/logwatch/default.conf/logfiles
+ doins conf/logfiles/*
+
+ insinto /usr/share/logwatch/default.conf/services
+ doins conf/services/*
+
+ insinto /usr/share/logwatch/default.conf/html
+ doins conf/html/*
+
+ # Make sure logwatch is run before anything else #100243
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}"/logwatch 00-logwatch
+
+ doman logwatch.8
+ dodoc README HOWTO-Customize-LogWatch
+
+ # Do last due to insopts modification.
+ insinto /usr/share/logwatch/scripts/logfiles
+ insopts -m755
+ doins -r scripts/logfiles/*
+}
+
+pkg_postinst() {
+ if [[ -e ${ROOT}/etc/cron.daily/logwatch ]] ; then
+ local md5=$(md5sum "${ROOT}"/etc/cron.daily/logwatch)
+ [[ ${md5} == "edb003cbc0686ed4cf37db16025635f3" ]] \
+ && rm -f "${ROOT}"/etc/cron.daily/logwatch \
+ || ewarn "You have two logwatch files in /etc/cron.daily/"
+ fi
+}