summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/memtest86+/files')
-rw-r--r--sys-apps/memtest86+/files/39_memtest86+67
-rw-r--r--sys-apps/memtest86+/files/39_memtest86+-r169
-rw-r--r--sys-apps/memtest86+/files/39_memtest86+-r2126
-rw-r--r--sys-apps/memtest86+/files/make-memtest86+-boot-floppy111
-rw-r--r--sys-apps/memtest86+/files/make-memtest86+-boot-floppy.139
-rw-r--r--sys-apps/memtest86+/files/memtest86+-5.01-gcc-473.patch33
-rw-r--r--sys-apps/memtest86+/files/memtest86+-5.01-hardcoded_cc.patch16
-rw-r--r--sys-apps/memtest86+/files/memtest86+-5.01-io-extern-inline.patch31
-rw-r--r--sys-apps/memtest86+/files/memtest86+-5.01-no-C-headers.patch49
-rw-r--r--sys-apps/memtest86+/files/memtest86+-5.01-no-clean.patch19
-rw-r--r--sys-apps/memtest86+/files/memtest86+-5.01-no-scp.patch14
-rw-r--r--sys-apps/memtest86+/files/memtest86+-5.01-objcopy.patch20
-rw-r--r--sys-apps/memtest86+/files/memtest86+-5.01-reboot-def.patch15
-rw-r--r--sys-apps/memtest86+/files/memtest86+-5.01-test-random-cflags.patch21
14 files changed, 126 insertions, 504 deletions
diff --git a/sys-apps/memtest86+/files/39_memtest86+ b/sys-apps/memtest86+/files/39_memtest86+
deleted file mode 100644
index 9c9067a5e736..000000000000
--- a/sys-apps/memtest86+/files/39_memtest86+
+++ /dev/null
@@ -1,67 +0,0 @@
-#!/bin/sh
-
-. /usr/share/grub/grub-mkconfig_lib
-
-memtest=/boot/memtest86plus/memtest
-
-memtestbsd=/boot/memtest86plus/memtest.netbsd
-
-if [ -f "${memtest}" ] && [ -f "${memtestbsd}" ]; then
- multiple_memtest=true
-fi
-
-submenu_indentation=""
-if [ "${multiple_memtest}" = "true" ] && [ "${GRUB_DISABLE_SUBMENU}" != "y" ]; then
- submenu_indentation="${grub_tab}"
- cat <<EOF
-submenu 'Memtest86+' {
-EOF
-fi
-
-if [ -f "${memtest}" ]; then
- gettext_printf "Found memtest image: %s\n" "${memtest}" >&2
-
- device="$("${grub_probe}" --target=device "${memtest}")"
- path="$(make_system_path_relative_to_its_root "${memtest}")"
- cat <<EOF
-${submenu_indentation}menuentry 'Memtest86+' {
-EOF
-
- if [ -n "{submenu_indentation}" ]; then
- prepare_grub_to_access_device "${device}" | grub_add_tab | grub_add_tab
- else
- prepare_grub_to_access_device "${device}" | grub_add_tab
- fi
-
- cat <<EOF
- ${submenu_indentation}linux16 "${path}"
-${submenu_indentation}}
-EOF
-fi
-
-if [ -f "${memtestbsd}" ]; then
- gettext_printf "Found memtest image: %s\n" "${memtestbsd}" >&2
-
- device="$("${grub_probe}" --target=device "${memtestbsd}")"
- path="$(make_system_path_relative_to_its_root "${memtestbsd}")"
- cat <<EOF
-${submenu_indentation}menuentry 'Memtest86+ (netbsd)' {
-EOF
-
- if [ -n "${submenu_indentation}" ]; then
- prepare_grub_to_access_device "${device}" | grub_add_tab | grub_add_tab
- else
- prepare_grub_to_access_device "${device}" | grub_add_tab
- fi
-
- cat <<EOF
- ${submenu_indentation}knetbsd "${path}"
-${submenu_indentation}}
-EOF
-fi
-
-if [ "${multiple_memtest}" = "true" ] && [ "${GRUB_DISABLE_SUBMENU}" != "y" ]; then
- cat <<EOF
-}
-EOF
-fi
diff --git a/sys-apps/memtest86+/files/39_memtest86+-r1 b/sys-apps/memtest86+/files/39_memtest86+-r1
deleted file mode 100644
index 20422b74d65a..000000000000
--- a/sys-apps/memtest86+/files/39_memtest86+-r1
+++ /dev/null
@@ -1,69 +0,0 @@
-#!/bin/sh
-
-. /usr/share/grub/grub-mkconfig_lib
-
-memtest=/boot/memtest86plus/memtest.bin
-
-memtestelf=/boot/memtest86plus/memtest
-
-if [ -f "${memtest}" ] && [ -f "${memtestelf}" ]; then
- multiple_memtest=true
-fi
-
-submenu_indentation=""
-if [ "${multiple_memtest}" = "true" ] && [ "${GRUB_DISABLE_SUBMENU}" != "y" ]; then
- submenu_indentation="${grub_tab}"
- cat <<EOF
-submenu 'Memtest86+' {
-EOF
-fi
-
-if [ -f "${memtest}" ]; then
- gettext_printf "Found memtest image: %s\n" "${memtest}" >&2
-
- device="$("${grub_probe}" --target=device "${memtest}")"
- path="$(make_system_path_relative_to_its_root "${memtest}")"
- cat <<EOF
-${submenu_indentation}menuentry 'Memtest86+' {
-EOF
-
- if [ -n "{submenu_indentation}" ]; then
- prepare_grub_to_access_device "${device}" | grub_add_tab | grub_add_tab
- else
- prepare_grub_to_access_device "${device}" | grub_add_tab
- fi
-
- cat <<EOF
- ${submenu_indentation}linux16 "${path}"
-${submenu_indentation}}
-EOF
-fi
-
-if [ -f "${memtestelf}" ]; then
- gettext_printf "Found memtest image: %s\n" "${memtestelf}" >&2
-
- device="$("${grub_probe}" --target=device "${memtestelf}")"
- path="$(make_system_path_relative_to_its_root "${memtestelf}")"
- cat <<EOF
-${submenu_indentation}menuentry 'Memtest86+ (ELF)' {
-EOF
-
- if [ -n "${submenu_indentation}" ]; then
- prepare_grub_to_access_device "${device}" | grub_add_tab | grub_add_tab
- else
- prepare_grub_to_access_device "${device}" | grub_add_tab
- fi
-
- # We use knetbsd as a lazy way of booting an ELF.
- # It's not actually related to NetBSD at all.
- cat <<EOF
- ${submenu_indentation}knetbsd "${path}"
-${submenu_indentation}}
-EOF
-fi
-
-if [ "${multiple_memtest}" = "true" ] && [ "${GRUB_DISABLE_SUBMENU}" != "y" ]; then
- cat <<EOF
-}
-EOF
-fi
diff --git a/sys-apps/memtest86+/files/39_memtest86+-r2 b/sys-apps/memtest86+/files/39_memtest86+-r2
new file mode 100644
index 000000000000..d53f83cc311a
--- /dev/null
+++ b/sys-apps/memtest86+/files/39_memtest86+-r2
@@ -0,0 +1,126 @@
+#!/bin/sh
+
+. /usr/share/grub/grub-mkconfig_lib
+
+mtbios32=/boot/memtest86plus/memtest32.bios
+mtbios64=/boot/memtest86plus/memtest64.bios
+mtefi32=/boot/memtest86plus/memtest.efi32
+mtefi64=/boot/memtest86plus/memtest.efi64
+
+if [ $(ls /boot/memtest86plus | wc -l) -gt 1 ]; then
+ multiple_memtest=true
+fi
+
+submenu_indentation=""
+if [ "${multiple_memtest}" = "true" ] && [ "${GRUB_DISABLE_SUBMENU}" != "y" ]; then
+ submenu_indentation="${grub_tab}"
+ cat <<EOF
+submenu 'Memtest86+' {
+EOF
+fi
+
+# Start bios32
+if [ -f "${mtbios32}" ]; then
+ gettext_printf "Found memtest image: %s\n" "${mtbios32}" >&2
+
+ device="$("${grub_probe}" --target=device "${mtbios32}")"
+ path="$(make_system_path_relative_to_its_root "${mtbios32}")"
+ cat <<EOF
+${submenu_indentation}if [ "x\$grub_platform" = xpc ]; then
+${submenu_indentation}menuentry 'Memtest86+ 32bit' {
+EOF
+
+ if [ -n "${submenu_indentation}" ]; then
+ prepare_grub_to_access_device "${device}" | grub_add_tab | grub_add_tab
+ else
+ prepare_grub_to_access_device "${device}" | grub_add_tab
+ fi
+
+ cat <<EOF
+ ${submenu_indentation}linux "${path}"
+${submenu_indentation}}
+${submenu_indentation}fi
+EOF
+fi
+# End bios32
+
+# Start bios64
+if [ -f "${mtbios64}" ]; then
+ gettext_printf "Found memtest image: %s\n" "${mtbios64}" >&2
+
+ device="$("${grub_probe}" --target=device "${mtbios64}")"
+ path="$(make_system_path_relative_to_its_root "${mtbios64}")"
+ cat <<EOF
+${submenu_indentation}if [ "x\$grub_platform" = xpc ]; then
+${submenu_indentation}menuentry 'Memtest86+ 64bit' {
+EOF
+
+ if [ -n "{submenu_indentation}" ]; then
+ prepare_grub_to_access_device "${device}" | grub_add_tab | grub_add_tab
+ else
+ prepare_grub_to_access_device "${device}" | grub_add_tab
+ fi
+
+ cat <<EOF
+ ${submenu_indentation}linux "${path}"
+${submenu_indentation}}
+${submenu_indentation}fi
+EOF
+fi
+# End bios64
+
+# Start efi32
+if [ -f "${mtefi32}" ]; then
+ gettext_printf "Found memtest image: %s\n" "${mtefi32}" >&2
+
+ device="$("${grub_probe}" --target=device "${mtefi32}")"
+ path="$(make_system_path_relative_to_its_root "${mtefi32}")"
+ cat <<EOF
+${submenu_indentation}if [ "x\$grub_platform" = xefi ]; then
+${submenu_indentation}menuentry 'Memtest86+ 32bit UEFI' {
+EOF
+
+ if [ -n "{submenu_indentation}" ]; then
+ prepare_grub_to_access_device "${device}" | grub_add_tab | grub_add_tab
+ else
+ prepare_grub_to_access_device "${device}" | grub_add_tab
+ fi
+
+ cat <<EOF
+ ${submenu_indentation}chainloader "${path}"
+${submenu_indentation}}
+${submenu_indentation}fi
+EOF
+fi
+# End efi32
+
+# Start efi64
+if [ -f "${mtefi64}" ]; then
+ gettext_printf "Found memtest image: %s\n" "${mtefi64}" >&2
+
+ device="$("${grub_probe}" --target=device "${mtefi64}")"
+ path="$(make_system_path_relative_to_its_root "${mtefi64}")"
+ cat <<EOF
+${submenu_indentation}if [ "x\$grub_platform" = xefi ]; then
+${submenu_indentation}menuentry 'Memtest86+ 64bit UEFI' {
+EOF
+
+ if [ -n "{submenu_indentation}" ]; then
+ prepare_grub_to_access_device "${device}" | grub_add_tab | grub_add_tab
+ else
+ prepare_grub_to_access_device "${device}" | grub_add_tab
+ fi
+
+ cat <<EOF
+ ${submenu_indentation}chainloader "${path}"
+${submenu_indentation}}
+${submenu_indentation}fi
+EOF
+fi
+#End efi64
+
+if [ "${multiple_memtest}" = "true" ] && [ "${GRUB_DISABLE_SUBMENU}" != "y" ]; then
+ cat <<EOF
+}
+EOF
+fi
diff --git a/sys-apps/memtest86+/files/make-memtest86+-boot-floppy b/sys-apps/memtest86+/files/make-memtest86+-boot-floppy
deleted file mode 100644
index 9c225c740bf4..000000000000
--- a/sys-apps/memtest86+/files/make-memtest86+-boot-floppy
+++ /dev/null
@@ -1,111 +0,0 @@
-#!/bin/sh
-#
-# Script for making a memtest86 boot floppy using GRUB as bootloader
-#
-
-# (c) 2003 Peter Loje Hansen <pl@2m.dk>
-# - original version
-# (c) 2004 Yann Dirson <dirson@debian.org>
-# - added parameters
-# - ability to work on a floppy image instead of a real floppy
-# - adapted patches from Martin Koeppe <martin@koeppe-net.de>, to use
-# mtools and install full grub
-
-# TODO:
-# - add a flag to generate a default boot entry for (hd0)
-
-set -e
-
-MEMTEST=/boot/memtest86plus/memtest.bin
-FLOPPYIMAGE=/dev/fd0
-GRUBBIN=/sbin/grub
-GRUBLIB=/lib/grub
-MFORMAT=/usr/bin/mformat
-
-arch=$(uname -m)
-
-case "$arch" in
- i386|i486|i686) GRUBARCH=i386-pc;;
- x86_64) GRUBARCH=x86_64-pc;;
- *) error "Unsupported architecture: $arch";;
-esac
-
-error()
-{
- echo >&2 "$0: $*"
- exit 1
-}
-
-needsarg()
-{
- [ $1 -ge 2 ] || error "syntax error"
-}
-
-[ -d $GRUBLIB ] || error "Can't find $GRUBLIB - did you install a recent grub package (0.95+cvs20040624 or later) ?"
-[ -x $MFORMAT ] || error "Can't find mformat - did you install the mtools package ?"
-
-while [ $# -gt 0 ]
-do
- case "$1" in
- --help) echo "$0 [--memtest $MEMTEST] [--floppyimage $FLOPPYIMAGE]"; exit 0 ;;
- --memtest) needsarg $#; MEMTEST="$2"; shift ;;
- --floppyimage) needsarg $#; FLOPPYIMAGE="$2"; shift ;;
- *) error "syntax error" ;;
- esac
- shift
-done
-
-MOUNTPOINT=$(mktemp -d)
-
-if [ -b "$FLOPPYIMAGE" ]
-then
- FINALDEV="$FLOPPYIMAGE"
- FLOPPYIMAGE="$(mktemp)"
-else
- FINALDEV=""
-fi
-
-echo "* Creating msdos file system"
-echo
-if [ ! -s "$FLOPPYIMAGE" ]; then
- # unless a non-empty image exists, create a blank one first
- dd bs=1024 count=1440 if=/dev/zero of="$FLOPPYIMAGE"
-fi
-# FIXME: "-f 1440" should probably be dropped
-mformat -i $FLOPPYIMAGE -f 1440 ::
-
-mmd -i $FLOPPYIMAGE ::/boot
-mmd -i $FLOPPYIMAGE ::/boot/grub
-
-echo
-echo "* Installing GRUB files"
-mcopy -v -i "$FLOPPYIMAGE" - ::/boot/grub/menu.lst <<EOF
-color green/black light-green/black
-default 0
-timeout 10
-title memtest
-kernel (fd0)/boot/memtest.bin
-EOF
-mcopy -v -i "$FLOPPYIMAGE" $GRUBLIB/$GRUBARCH/* ::/boot/grub
-
-echo
-echo "* Installing $MEMTEST"
-mcopy -v -i "$FLOPPYIMAGE" "$MEMTEST" ::/boot/memtest.bin
-
-echo
-echo -n "* Installing GRUB"
-$GRUBBIN --batch --device-map=/dev/null <<EOF
-device (fd0) $FLOPPYIMAGE
-root (fd0)
-setup (fd0)
-quit
-EOF
-
-if [ -n "$FINALDEV" ]; then
- echo
- echo "Insert a writable floppy for $FINALDEV and press enter"
- read FOO
-
- dd bs=1024 if="$FLOPPYIMAGE" of="$FINALDEV"
- rm "$FLOPPYIMAGE"
-fi
diff --git a/sys-apps/memtest86+/files/make-memtest86+-boot-floppy.1 b/sys-apps/memtest86+/files/make-memtest86+-boot-floppy.1
deleted file mode 100644
index e1283e5efc8f..000000000000
--- a/sys-apps/memtest86+/files/make-memtest86+-boot-floppy.1
+++ /dev/null
@@ -1,39 +0,0 @@
-.\" Man page for make-memtest86+-boot-floppy
-
-.TH make-memtest86+-boot-floppy 1
-
-.SH NAME
-make-memtest86+-boot-floppy \- create a memtest86+ boot-floppy using GRUB.
-
-.SH SYNOPSIS
-
-.B make-memtest86+-boot-floppy [ \-\-memtest
-.I <path to memtest86+-image>
-.B ] [ \-\-floppyimage
-.I <path to floppyimage/device>
-.B ]
-
-.SH DESCRIPTION
-.B make-memtest86+-boot-floppy
-can create a memtest86+ boot floppy using GRUB as the bootloader.
-
-.SH OPTIONS
-
-.IP "\-\-memtest <path to the memtest-image>"
-Path to the memtest86+-image, default is /boot/memtest86+.bin.
-
-.IP "\-\-floppyimage <path to the floppyimage or device>"
-File or device where the boot-image should be written to, default is /dev/fd0.
-
-.IP "\-\-help"
-Display a short message about the options of the tool.
-
-.SH AUTHOR
-This man-page has been written by Thomas Schmidt <thomas@thsnet.de>
-.PP
-Permission is granted to copy, distribute and/or modify this document under
-the terms of the GNU General Public License, Version 2 any
-later version published by the Free Software Foundation.
-.PP
-On Debian systems, the complete text of the GNU General Public
-License can be found in /usr/share/common\-licenses/GPL.
diff --git a/sys-apps/memtest86+/files/memtest86+-5.01-gcc-473.patch b/sys-apps/memtest86+/files/memtest86+-5.01-gcc-473.patch
deleted file mode 100644
index af011d67c705..000000000000
--- a/sys-apps/memtest86+/files/memtest86+-5.01-gcc-473.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-http://forum.canardpc.com/threads/110950-fix-controller-loop-error
-
---- memtest86+-5.01/controller.c
-+++ memtest86+-5.01/controller.c
-@@ -292,7 +292,7 @@ static void setup_nhm(void)
-
- /* First, locate the PCI bus where the MCH is located */
-
-- for(i = 0; i < sizeof(possible_nhm_bus); i++) {
-+ for(i = 0; i < sizeof(possible_nhm_bus) / sizeof(possible_nhm_bus[0]); i++) {
- pci_conf_read( possible_nhm_bus[i], 3, 4, 0x00, 2, &vid);
- pci_conf_read( possible_nhm_bus[i], 3, 4, 0x02, 2, &did);
- vid &= 0xFFFF;
-@@ -327,7 +327,7 @@ static void setup_nhm32(void)
- ctrl.mode = ECC_NONE;
-
- /* First, locate the PCI bus where the MCH is located */
-- for(i = 0; i < sizeof(possible_nhm_bus); i++) {
-+ for(i = 0; i < sizeof(possible_nhm_bus) / sizeof(possible_nhm_bus[0]); i++) {
- pci_conf_read( possible_nhm_bus[i], 3, 4, 0x00, 2, &vid);
- pci_conf_read( possible_nhm_bus[i], 3, 4, 0x02, 2, &did);
- vid &= 0xFFFF;
---- memtest86+-5.01/Makefile
-+++ memtest86+-5.01/Makefile
-@@ -12,7 +12,7 @@ FDISK=/dev/fd0
- AS=as -32
- CC=gcc
-
--CFLAGS= -Wall -march=i486 -m32 -O1 -fomit-frame-pointer -fno-builtin \
-+CFLAGS= -Wall -march=i486 -m32 -O0 -fomit-frame-pointer -fno-builtin \
- -ffreestanding -fPIC $(SMP_FL) -fno-stack-protector
-
- OBJS= head.o reloc.o main.o test.o init.o lib.o patn.o screen_buffer.o \
diff --git a/sys-apps/memtest86+/files/memtest86+-5.01-hardcoded_cc.patch b/sys-apps/memtest86+/files/memtest86+-5.01-hardcoded_cc.patch
deleted file mode 100644
index 21b51c5b7fff..000000000000
--- a/sys-apps/memtest86+/files/memtest86+-5.01-hardcoded_cc.patch
+++ /dev/null
@@ -1,16 +0,0 @@
---- a/Makefile.orig 2015-02-01 01:08:33.000000000 +0300
-+++ b/Makefile 2015-02-01 01:10:17.624757244 +0300
-@@ -9,11 +9,10 @@
- #
- FDISK=/dev/fd0
-
--AS=as -32
--CC=gcc
--
- CFLAGS= -Wall -march=i486 -m32 -O0 -fomit-frame-pointer -fno-builtin \
- -ffreestanding -fPIC $(SMP_FL) -fno-stack-protector
-+CPPFLAGS= -m32
-+ASFLAGS= -32
-
- OBJS= head.o reloc.o main.o test.o init.o lib.o patn.o screen_buffer.o \
- config.o cpuid.o linuxbios.o pci.o memsize.o spd.o error.o dmi.o controller.o \
diff --git a/sys-apps/memtest86+/files/memtest86+-5.01-io-extern-inline.patch b/sys-apps/memtest86+/files/memtest86+-5.01-io-extern-inline.patch
deleted file mode 100644
index 682dd5d01a1e..000000000000
--- a/sys-apps/memtest86+/files/memtest86+-5.01-io-extern-inline.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-http://forum.canardpc.com/threads/110951-fix-build-with-newer-gcc-versions
-
-the meaning of extern inline changed between standards. use static inline
-for these tiny I/O functions everywhere to keep things simple.
-
---- a/io.h
-+++ b/io.h
-@@ -31,6 +31,6 @@
- */
-
- #define __OUT1(s,x) \
--extern inline void __out##s(unsigned x value, unsigned short port) {
-+static inline void __out##s(unsigned x value, unsigned short port) {
-
- #define __OUT2(s,s1,s2) \
-@@ -43,6 +43,6 @@
- __OUT1(s##c_p,x) __OUT2(s,s1,"") : : "a" (value), "id" (port)); SLOW_DOWN_IO; }
-
- #define __IN1(s) \
--extern inline RETURN_TYPE __in##s(unsigned short port) { RETURN_TYPE _v;
-+static inline RETURN_TYPE __in##s(unsigned short port) { RETURN_TYPE _v;
-
- #define __IN2(s,s1,s2) \
-@@ -55,6 +55,6 @@
- __IN1(s##c_p) __IN2(s,s1,"") : "=a" (_v) : "id" (port) ,##i ); SLOW_DOWN_IO; return _v; }
-
- #define __OUTS(s) \
--extern inline void outs##s(unsigned short port, const void * addr, unsigned long count) \
-+static inline void outs##s(unsigned short port, const void * addr, unsigned long count) \
- { __asm__ __volatile__ ("cld ; rep ; outs" #s \
- : "=S" (addr), "=c" (count) : "d" (port),"0" (addr),"1" (count)); }
diff --git a/sys-apps/memtest86+/files/memtest86+-5.01-no-C-headers.patch b/sys-apps/memtest86+/files/memtest86+-5.01-no-C-headers.patch
deleted file mode 100644
index ce7f906a19d5..000000000000
--- a/sys-apps/memtest86+/files/memtest86+-5.01-no-C-headers.patch
+++ /dev/null
@@ -1,49 +0,0 @@
-http://forum.canardpc.com/threads/110955-PATCH-don-t-pull-in-system-headers
-
-avoid using C library headers as it'd mean we'd need 32-bit glibc files available
-
-https://bugs.gentoo.org/592638
-
---- a/dmi.c
-+++ b/dmi.c
-@@ -10,7 +10,7 @@
-
-
- #include "test.h"
--#include <stdint.h>
-+#include "stdint.h"
-
-
- #define round_up(x,y) (((x) + (y) - 1) & ~((y)-1))
---- a/test.c
-+++ b/test.c
-@@ -14,7 +14,28 @@
- #include "stdint.h"
- #include "cpuid.h"
- #include "smp.h"
--#include <sys/io.h>
-+
-+static inline unsigned char
-+inb_p (unsigned short int __port)
-+{
-+ unsigned char _v;
-+
-+ __asm__ __volatile__ ("inb %w1,%0\noutb %%al,$0x80":"=a" (_v):"Nd" (__port));
-+ return _v;
-+}
-+
-+static inline void
-+outb (unsigned char __value, unsigned short int __port)
-+{
-+ __asm__ __volatile__ ("outb %b0,%w1": :"a" (__value), "Nd" (__port));
-+}
-+
-+static inline void
-+outb_p (unsigned char __value, unsigned short int __port)
-+{
-+ __asm__ __volatile__ ("outb %b0,%w1\noutb %%al,$0x80": :"a" (__value),
-+ "Nd" (__port));
-+}
-
- extern struct cpu_ident cpu_id;
- extern volatile int mstr_cpu;
diff --git a/sys-apps/memtest86+/files/memtest86+-5.01-no-clean.patch b/sys-apps/memtest86+/files/memtest86+-5.01-no-clean.patch
deleted file mode 100644
index e9cbf10399c3..000000000000
--- a/sys-apps/memtest86+/files/memtest86+-5.01-no-clean.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-http://forum.canardpc.com/threads/110954-PATCH-fix-parallel-build-issues
-
-
-don't run the clean target when building all as we run into parallel races:
- - memtest kicks off building of a bunch of .o files
- - clean runs in parallel which runs `rm` and deletes some of the new .o
- - memtest goes to link and fails because objects are missing
-
---- a/Makefile
-+++ b/Makefile
-@@ -19,7 +19,7 @@
- smp.o vmem.o random.o
-
-
--all: clean memtest.bin memtest
-+all: memtest.bin memtest
-
- # Link it statically once so I know I don't have undefined
- # symbols and then link it dynamically so I have full
diff --git a/sys-apps/memtest86+/files/memtest86+-5.01-no-scp.patch b/sys-apps/memtest86+/files/memtest86+-5.01-no-scp.patch
deleted file mode 100644
index 8d830e297ec2..000000000000
--- a/sys-apps/memtest86+/files/memtest86+-5.01-no-scp.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-http://forum.canardpc.com/threads/110953-PATCH-don-t-try-to-scp-after-building
-
-this makes no sense in a sane build world
-
---- a/Makefile
-+++ b/Makefile
-@@ -21,7 +21,6 @@
-
-
- all: clean memtest.bin memtest
-- scp memtest.bin root@192.168.0.12:/srv/tftp/mt86plus
-
- # Link it statically once so I know I don't have undefined
- # symbols and then link it dynamically so I have full
diff --git a/sys-apps/memtest86+/files/memtest86+-5.01-objcopy.patch b/sys-apps/memtest86+/files/memtest86+-5.01-objcopy.patch
deleted file mode 100644
index 5effe20027a9..000000000000
--- a/sys-apps/memtest86+/files/memtest86+-5.01-objcopy.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-Allow 'objcopy' override with user's OBJCOPY.
---- a/Makefile
-+++ b/Makefile
-@@ -8,6 +8,7 @@
- # Path for the floppy disk device
- #
- FDISK=/dev/fd0
-+OBJCOPY=objcopy
-
- CFLAGS= -Wall -march=i486 -m32 -O0 -fomit-frame-pointer -fno-builtin \
- -ffreestanding -fPIC $(SMP_FL) -fno-stack-protector
-@@ -30,7 +31,7 @@ memtest_shared: $(OBJS) memtest_shared.lds Makefile
- $(LD) -shared -Bsymbolic -T memtest_shared.lds -o $@ $(OBJS)
-
- memtest_shared.bin: memtest_shared
-- objcopy -O binary $< memtest_shared.bin
-+ $(OBJCOPY) -O binary $< memtest_shared.bin
-
- memtest: memtest_shared.bin memtest.lds
- $(LD) -s -T memtest.lds -b binary memtest_shared.bin -o $@
diff --git a/sys-apps/memtest86+/files/memtest86+-5.01-reboot-def.patch b/sys-apps/memtest86+/files/memtest86+-5.01-reboot-def.patch
deleted file mode 100644
index f4b42feb5fb3..000000000000
--- a/sys-apps/memtest86+/files/memtest86+-5.01-reboot-def.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-http://forum.canardpc.com/threads/110952-fix-build-due-to-missing-reboot-symbol
-
-the reboot func is used elsewhere, so don't mark it inline
-
---- a/lib.c
-+++ b/lib.c
-@@ -33,7 +33,7 @@ struct ascii_map_str {
- int keycode;
- };
-
--inline void reboot(void)
-+void reboot(void)
- {
-
- /* tell the BIOS to do a cold start */
diff --git a/sys-apps/memtest86+/files/memtest86+-5.01-test-random-cflags.patch b/sys-apps/memtest86+/files/memtest86+-5.01-test-random-cflags.patch
deleted file mode 100644
index dcdccb8c6e97..000000000000
--- a/sys-apps/memtest86+/files/memtest86+-5.01-test-random-cflags.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-make sure we re-use the existing CFLAGS settings so that we get all the right
-flags (like -fno-stack-protector). just append the few changes we want (the
-optimization levels).
-
-https://bugs.gentoo.org/590974
-
---- a/Makefile
-+++ b/Makefile
-@@ -52,10 +52,10 @@ reloc.o: reloc.c
- $(CC) -c $(CFLAGS) -fno-strict-aliasing reloc.c
-
- test.o: test.c
-- $(CC) -c -Wall -march=i486 -m32 -O0 -fomit-frame-pointer -fno-builtin -ffreestanding test.c
-+test.o: CFLAGS += -O0 -fno-PIC
-
- random.o: random.c
-- $(CC) -c -Wall -march=i486 -m32 -O3 -fomit-frame-pointer -fno-builtin -ffreestanding random.c
-+random.o: CFLAGS += -O3 -fno-PIC
-
- # rule for build number generation
- build_number: