summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/memtest86-bin')
-rw-r--r--sys-apps/memtest86-bin/memtest86-bin-9.2.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/sys-apps/memtest86-bin/memtest86-bin-9.2.ebuild b/sys-apps/memtest86-bin/memtest86-bin-9.2.ebuild
index 97f87cab2411..bcd35375627c 100644
--- a/sys-apps/memtest86-bin/memtest86-bin-9.2.ebuild
+++ b/sys-apps/memtest86-bin/memtest86-bin-9.2.ebuild
@@ -33,3 +33,11 @@ src_install() {
dodoc MemTest86_User_Guide_UEFI.pdf
}
+
+pkg_postinst() {
+ mount-boot_pkg_postinst
+
+ if [ ! -e /sys/firmware/efi ]; then
+ ewarn "WARNING: You appear to be booted in BIOS mode but ${PN} is an EFI-only tool."
+ fi
+}