summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/memtester/memtester-4.3.0.ebuild')
-rw-r--r--sys-apps/memtester/memtester-4.3.0.ebuild16
1 files changed, 9 insertions, 7 deletions
diff --git a/sys-apps/memtester/memtester-4.3.0.ebuild b/sys-apps/memtester/memtester-4.3.0.ebuild
index 56a07613ef14..cccff64b5d43 100644
--- a/sys-apps/memtester/memtester-4.3.0.ebuild
+++ b/sys-apps/memtester/memtester-4.3.0.ebuild
@@ -1,23 +1,25 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
+EAPI=7
inherit toolchain-funcs
DESCRIPTION="userspace utility for testing the memory subsystem for faults"
HOMEPAGE="http://pyropus.ca/software/memtester/"
-SRC_URI="http://pyropus.ca/software/memtester/${P}.tar.gz
+SRC_URI="
+ http://pyropus.ca/software/memtester/${P}.tar.gz
http://pyropus.ca/software/memtester/old-versions/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm ~ia64 ~mips ppc ppc64 sparc x86"
-IUSE=""
-src_prepare() {
- echo "$(tc-getCC) ${CFLAGS} ${CPPFLAGS} -DPOSIX -c" > conf-cc
- echo "$(tc-getCC) ${CFLAGS} ${LDFLAGS}" > conf-ld
+PATCHES=( "${FILESDIR}"/${PN}-4.3.0-fix-gcc10-fno-common.patch )
+
+src_configure() {
+ echo "$(tc-getCC) ${CFLAGS} ${CPPFLAGS} -DPOSIX -c" > conf-cc || die
+ echo "$(tc-getCC) ${CFLAGS} ${LDFLAGS}" > conf-ld || die
}
src_install() {