summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/miscfiles/miscfiles-1.5-r4.ebuild')
-rw-r--r--sys-apps/miscfiles/miscfiles-1.5-r4.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/sys-apps/miscfiles/miscfiles-1.5-r4.ebuild b/sys-apps/miscfiles/miscfiles-1.5-r4.ebuild
new file mode 100644
index 000000000000..e0773aba5f24
--- /dev/null
+++ b/sys-apps/miscfiles/miscfiles-1.5-r4.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+UNI_PV="10.0.0"
+DESCRIPTION="Miscellaneous files"
+HOMEPAGE="https://savannah.gnu.org/projects/miscfiles/"
+# https://www.unicode.org/Public/${UNI_PV}/ucd/UnicodeData.txt
+SRC_URI="mirror://gnu/miscfiles/${P}.tar.gz
+ https://dev.gentoo.org/~whissi/dist/${PN}/UnicodeData-${UNI_PV}.txt.xz"
+
+LICENSE="GPL-2 unicode"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="minimal"
+
+src_prepare() {
+ default
+
+ mv "${WORKDIR}"/UnicodeData-${UNI_PV}.txt unicode || die
+}
+
+src_configure() {
+ econf --datadir="${EPREFIX}"/usr/share/misc
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc NEWS ORIGIN README dict-README
+
+ # not sure if this is still needed ...
+ dodir /usr/share/dict
+ cd "${ED}"/usr/share/misc || die
+ mv $(awk '$1=="dictfiles"{$1="";$2="";print}' "${S}"/Makefile) ../dict/ || die
+ cd ../dict || die
+ ln -s web2 words || die
+ ln -s web2a extra.words || die
+
+ if use minimal ; then
+ pushd "${ED}"/usr/share/dict || die
+ rm -f words extra.words || die
+ gzip -9 * || die
+ ln -s web2.gz words || die
+ ln -s web2a.gz extra.words || die
+ ln -s connectives{.gz,} || die
+ ln -s propernames{.gz,} || die
+ popd || die
+ rm -r "${ED}"/usr/share/misc || die
+ fi
+}
+
+pkg_postinst() {
+ if [[ -z ${ROOT} ]] && type -P create-cracklib-dict >/dev/null ; then
+ ebegin "Regenerating cracklib dictionary"
+ create-cracklib-dict "${EPREFIX}"/usr/share/dict/* > /dev/null
+ eend $?
+ fi
+
+ # pkg_postinst isn't supposed to fail
+ return 0
+}