summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/paxctld/paxctld-1.0.ebuild')
-rw-r--r--sys-apps/paxctld/paxctld-1.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-apps/paxctld/paxctld-1.0.ebuild b/sys-apps/paxctld/paxctld-1.0.ebuild
new file mode 100644
index 000000000000..26106e85b21e
--- /dev/null
+++ b/sys-apps/paxctld/paxctld-1.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="PaX flags maintenance daemon"
+HOMEPAGE="http://www.grsecurity.net/"
+SRC_URI="http://dev.gentoo.org/~blueness/hardened-sources/paxctld/${PN}_${PV}.orig.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="pam"
+
+RDEPEND=""
+DEPEND=""
+
+src_prepare() {
+ # Respect Gentoo flags and don't strip
+ sed -i \
+ -e '/^CC/d' \
+ -e '/^CFLAGS/d' \
+ -e '/^LDFLAGS/d' \
+ -e '/STRIP/d' \
+ Makefile
+}