summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/plocate')
-rw-r--r--sys-apps/plocate/Manifest1
-rw-r--r--sys-apps/plocate/plocate-1.1.14.ebuild81
2 files changed, 0 insertions, 82 deletions
diff --git a/sys-apps/plocate/Manifest b/sys-apps/plocate/Manifest
index b0d04228471f..9f988c24398e 100644
--- a/sys-apps/plocate/Manifest
+++ b/sys-apps/plocate/Manifest
@@ -1,2 +1 @@
-DIST plocate-1.1.14.tar.gz 73037 BLAKE2B 032963fa268d31664a8abd38ca501aacda4cfe29c8fd1e41228a4cfd5976174736e8d8f8aa1265de8953ec63211700da73e4cdd3eef42c059a638cdd9cd59379 SHA512 c97c9e4aed785af6bd8c2a30d5d5c7190cb4c513f1d6b66bb2885c9550b4cd39f097fac4bd736c211a921955422d0c27b5f35713f03ebe136450cb724fcfe600
DIST plocate-1.1.15.tar.gz 73274 BLAKE2B 72dba287ba3357d2fa541542bf5e9d283eac672b7f3b2eebab687ecec930d6e91400eeb0f24c97d6133d69cae0308bc4473b7c8cbc5e263dd18ae8a7728a42a4 SHA512 772f82af38fd7b61fa51ac31f71d4a855542cfa617867da54b5ad8202f49f9e1861064a01e9b8f0937c3da902d84f19a50c1d0e4f037a491a9a6819b2413cfa1
diff --git a/sys-apps/plocate/plocate-1.1.14.ebuild b/sys-apps/plocate/plocate-1.1.14.ebuild
deleted file mode 100644
index 1c92c6cde6cf..000000000000
--- a/sys-apps/plocate/plocate-1.1.14.ebuild
+++ /dev/null
@@ -1,81 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit linux-info meson systemd
-
-DESCRIPTION="Posting locate is a much faster locate"
-HOMEPAGE="https://plocate.sesse.net/"
-SRC_URI="https://plocate.sesse.net/download/${P}.tar.gz"
-
-# GPL-2 for updatedb
-# GPL-2+ for plocate itself
-LICENSE="GPL-2 GPL-2+"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64"
-IUSE="+io-uring"
-
-RDEPEND="
- acct-group/locate
- app-arch/zstd:=
- io-uring? ( sys-libs/liburing:= )
- !sys-apps/mlocate
-"
-DEPEND="${RDEPEND}"
-
-CONFIG_CHECK="~IO_URING"
-ERROR_IO_URING="required for USE=io-uring"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.1.10-meson-use-feature-option-for-libiouring.patch
-)
-
-src_prepare() {
- # We'll install the manpage ourself to locate.1
- sed -i "/install_man('plocate.1')/d" meson.build || die
-
- default
-}
-
-src_configure() {
- local emesonargs=(
- -Dlocategroup=locate
- -Dinstall_systemd=true
- -Dinstall_cron=false
- -Dsystemunitdir="$(systemd_get_systemunitdir)"
- "$(meson_feature io-uring use_libiouring)"
- )
- meson_src_configure
-}
-
-src_install() {
- meson_src_install
- dodoc README NEWS
- newman "${S}"/${PN}.1 locate.1
- dosym plocate /usr/bin/locate
-
- insinto /etc
- doins "${FILESDIR}"/updatedb.conf
- doins "${FILESDIR}"/plocate-cron.conf
- fperms 0644 /etc/{updatedb,plocate-cron}.conf
-
- insinto /etc/cron.daily
- # Ensure that the cron file has the same name as the
- # systemd-timer, to avoid plocate being run twice daily on systems
- # with a systemd compatiblity layer. See also bug #780351.
- newins "${FILESDIR}"/plocate.cron plocate-updatedb
- fperms 0755 /etc/cron.daily/plocate-updatedb
-
- systemd_dounit "${BUILD_DIR}"/${PN}-updatedb.service "${S}"/${PN}-updatedb.timer
-}
-
-pkg_postinst() {
- if [[ -z "${REPLACING_VERSIONS}" ]] ; then
- elog "The database for the locate command is generated daily by a cron job,"
- elog "if you install for the first time you can run the updatedb command manually now."
- elog
- elog "Note that the ${EROOT}/etc/updatedb.conf file is generic,"
- elog "please customize it to your system requirements."
- fi
-}