summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/razer-cli')
-rw-r--r--sys-apps/razer-cli/Manifest2
-rw-r--r--sys-apps/razer-cli/files/razer-cli-setup.patch9
-rw-r--r--sys-apps/razer-cli/metadata.xml20
-rw-r--r--sys-apps/razer-cli/razer-cli-2.2.0-r1.ebuild37
-rw-r--r--sys-apps/razer-cli/razer-cli-2.2.1-r1.ebuild42
5 files changed, 110 insertions, 0 deletions
diff --git a/sys-apps/razer-cli/Manifest b/sys-apps/razer-cli/Manifest
new file mode 100644
index 000000000000..2e3580d0364b
--- /dev/null
+++ b/sys-apps/razer-cli/Manifest
@@ -0,0 +1,2 @@
+DIST razer-cli-2.2.0.gh.tar.gz 6985679 BLAKE2B 2ed6a343759a2fb1a74accc509fd862330226bb407cc1f6c276ab06d1c6719ee5c358041dfd35ad596885499c5affbef79fdc14aed331b466f2d383e5d552b26 SHA512 a82b2bc29bee30a0994c3f061809e63ffb2b8cca651ad09641fcf9bdc3dd370614ca6d6d8305345573810e20dc2cde96a48979bcfad1473a83c509cd322ab471
+DIST razer-cli-2.2.1.gh.tar.gz 6985735 BLAKE2B 0ee1f4a123ca7bd853ca71b5962bd26339c0a51941f8d51e478d43ba96559227d89383d9ba8bf054cb9dec708d6abc0903a9537a55a05eecb56b0e4448e78001 SHA512 e0b6302ea599c578f9445ebfba90bc942c9fa1aec02ad836790318ea91b7f07f0c38aca49267b320b0576fdcc11c9ab98da019026eb06476ec016619b5aafe65
diff --git a/sys-apps/razer-cli/files/razer-cli-setup.patch b/sys-apps/razer-cli/files/razer-cli-setup.patch
new file mode 100644
index 000000000000..de0aee5cc68b
--- /dev/null
+++ b/sys-apps/razer-cli/files/razer-cli-setup.patch
@@ -0,0 +1,9 @@
+--- a/setup.py
++++ b/setup.py
+@@ -20,6 +20,4 @@ setup(
+ packages=find_packages(),
+ entry_points={"console_scripts": ["razer-cli=razer_cli.razer_cli.main:main"]},
+ python_requires=">=3.6",
+- package_data={'': ['razer_cli/razer_cli/man_pages']},
+- include_package_data=True,
+ )
diff --git a/sys-apps/razer-cli/metadata.xml b/sys-apps/razer-cli/metadata.xml
new file mode 100644
index 000000000000..2141ca61c288
--- /dev/null
+++ b/sys-apps/razer-cli/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+
+<pkgmetadata>
+ <maintainer type="person">
+ <email>xgqt@gentoo.org</email>
+ <name>Maciej Barć</name>
+ </maintainer>
+ <longdescription>
+ With this command line interface you can configure your Razer peripherals,
+ such as keyboard and mouse, set their colors and effects, etc. The most
+ simple use case (for which this tool was originally developed) is to use it
+ in symbiosis with pywal. Then this tool will set your Razer colors to
+ Pywal's colors.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/LoLei/razer-cli/-/issues/</bugs-to>
+ <remote-id type="github">LoLei/razer-cli</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-apps/razer-cli/razer-cli-2.2.0-r1.ebuild b/sys-apps/razer-cli/razer-cli-2.2.0-r1.ebuild
new file mode 100644
index 000000000000..5c523710f54b
--- /dev/null
+++ b/sys-apps/razer-cli/razer-cli-2.2.0-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Command line interface for controlling Razer devices on Linux"
+HOMEPAGE="https://github.com/LoLei/razer-cli/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/LoLei/${PN}.git"
+else
+ SRC_URI="https://github.com/LoLei/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ sys-apps/openrazer[client,daemon,${PYTHON_USEDEP}]
+ x11-apps/xrdb
+"
+BDEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/${PN}-setup.patch )
+
+distutils_enable_tests unittest
+
+src_test() {
+ virtx distutils-r1_src_test
+}
diff --git a/sys-apps/razer-cli/razer-cli-2.2.1-r1.ebuild b/sys-apps/razer-cli/razer-cli-2.2.1-r1.ebuild
new file mode 100644
index 000000000000..ca17fe5b39aa
--- /dev/null
+++ b/sys-apps/razer-cli/razer-cli-2.2.1-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Command line interface for controlling Razer devices on Linux"
+HOMEPAGE="https://github.com/LoLei/razer-cli/"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/LoLei/${PN}.git"
+else
+ SRC_URI="https://github.com/LoLei/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+RDEPEND="
+ sys-apps/openrazer[client,daemon,${PYTHON_USEDEP}]
+ x11-apps/xrdb
+"
+BDEPEND="
+ ${RDEPEND}
+"
+
+PATCHES=( "${FILESDIR}/${PN}-setup.patch" )
+
+distutils_enable_tests unittest
+
+src_test() {
+ virtx distutils-r1_src_test
+}