summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/readahead-list/files/1.20060421.1016/0003-Simplify-setting-up-Large-File-Support-use-AC_SYS_LA.patch')
-rw-r--r--sys-apps/readahead-list/files/1.20060421.1016/0003-Simplify-setting-up-Large-File-Support-use-AC_SYS_LA.patch43
1 files changed, 43 insertions, 0 deletions
diff --git a/sys-apps/readahead-list/files/1.20060421.1016/0003-Simplify-setting-up-Large-File-Support-use-AC_SYS_LA.patch b/sys-apps/readahead-list/files/1.20060421.1016/0003-Simplify-setting-up-Large-File-Support-use-AC_SYS_LA.patch
new file mode 100644
index 000000000000..dc1a092eb117
--- /dev/null
+++ b/sys-apps/readahead-list/files/1.20060421.1016/0003-Simplify-setting-up-Large-File-Support-use-AC_SYS_LA.patch
@@ -0,0 +1,43 @@
+https://github.com/robbat2/readahead-list/pull/1
+
+From 9d7b7a13ac265b76bb7933072a20bf462e5377a6 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Sun, 25 Dec 2022 20:35:38 +0000
+Subject: [PATCH 3/6] Simplify setting up Large File Support (use
+ AC_SYS_LARGEFILE)
+
+Signed-off-by: Sam James <sam@gentoo.org>
+--- a/configure.ac
++++ b/configure.ac
+@@ -13,18 +13,15 @@ AC_PREREQ([2.71])
+ # date +"1.%Y%m%d.%H%M" -u
+ AC_INIT([readahead-list],[1.20060421.1016],[Robin H. Johnson robbat2@orbis-terrarum.net],[readahead-list])
+
+-LFS_CPPFLAGS="-D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGEFILE64_SOURCE"
+ WARN_CFLAGS="-Wall -W"
+ CFLAGS="$CFLAGS $WARN_CFLAGS"
+ CXXFLAGS="$CXXFLAGS $WARN_CFLAGS"
+-CPPFLAGS="$CPPFLAGS $LFS_CPPFLAGS"
+-export CFLAGS CXXFLAGS CPPFLAGS
++export CFLAGS CXXFLAGS
+
+ AC_CONFIG_AUX_DIR(config)
+ AC_CONFIG_HEADERS([config.h])
+ AM_INIT_AUTOMAKE([dist-bzip2])
+
+-
+ # Checks for programs.
+ AC_PROG_AWK
+ AC_PROG_CC
+@@ -43,6 +40,8 @@ AC_PROG_RANLIB
+ # Provides _GNU_SOURCE for readahead()
+ AC_USE_SYSTEM_EXTENSIONS
+
++AC_SYS_LARGEFILE
++
+ # Checks for header files.
+ AC_CHECK_HEADERS([ errno.h fcntl.h getopt.h linux/fs.h sched.h stdio.h stdlib.h string.h sys/ioctl.h sys/mman.h sys/syscall.h sys/types.h unistd.h ])
+
+--
+2.39.0
+