summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/readahead-list')
-rw-r--r--sys-apps/readahead-list/Manifest1
-rw-r--r--sys-apps/readahead-list/files/conf.d-readahead-list16
-rw-r--r--sys-apps/readahead-list/files/init.d-readahead-list23
-rw-r--r--sys-apps/readahead-list/files/init.d-readahead-list-early23
-rw-r--r--sys-apps/readahead-list/files/readahead-list-1.20060421.1016-gcc-4.3.patch10
-rw-r--r--sys-apps/readahead-list/metadata.xml9
-rw-r--r--sys-apps/readahead-list/readahead-list-1.20060421.1016-r1.ebuild59
-rw-r--r--sys-apps/readahead-list/readahead-list-1.20060421.1016.ebuild61
8 files changed, 202 insertions, 0 deletions
diff --git a/sys-apps/readahead-list/Manifest b/sys-apps/readahead-list/Manifest
new file mode 100644
index 000000000000..c54c0dc37f94
--- /dev/null
+++ b/sys-apps/readahead-list/Manifest
@@ -0,0 +1 @@
+DIST readahead-list-1.20060421.1016.tar.bz2 108337 SHA256 b031f92e89756f4fd19ad2860f5d6ede80e57ddd1e973376c49e43fe142a6a82
diff --git a/sys-apps/readahead-list/files/conf.d-readahead-list b/sys-apps/readahead-list/files/conf.d-readahead-list
new file mode 100644
index 000000000000..2a79bec158a8
--- /dev/null
+++ b/sys-apps/readahead-list/files/conf.d-readahead-list
@@ -0,0 +1,16 @@
+#!/sbin/runscript
+# Copyright 2005 Robin H. Johnson <robbat2@orbis-terrarum.net>
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# this list is intended for usage very early
+READAHEAD_LIST_exec_sbin_rc="/etc/readahead-list/exec_sbin_rc"
+
+# per-runlevel
+READAHEAD_LIST_runlevel_boot="/etc/readahead-list/runlevel-boot"
+READAHEAD_LIST_runlevel_default="/etc/readahead-list/runlevel-default"
+
+READAHEAD_LIST_call_early="${!READAHEAD_LIST_exec_sbin_rc} ${!READAHEAD_LIST_runlevel_boot}"
+READAHEAD_LIST_call_main="${!READAHEAD_LIST_runlevel_default}"
+
+# vim: ts=4 sw=4
diff --git a/sys-apps/readahead-list/files/init.d-readahead-list b/sys-apps/readahead-list/files/init.d-readahead-list
new file mode 100644
index 000000000000..c2a90aceff0b
--- /dev/null
+++ b/sys-apps/readahead-list/files/init.d-readahead-list
@@ -0,0 +1,23 @@
+#!/sbin/runscript
+# Copyright 2005 Robin H. Johnson <robbat2@orbis-terrarum.net>
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+depend() {
+ after localmount
+ # this should start as early as possible
+ # we can't do 'before *' as that breaks it
+ before clock bootmisc consolefont keymaps rmnologin serial urandom
+}
+
+start() {
+ # force reading
+ source /etc/conf.d/readahead-list
+
+ f="${READAHEAD_LIST_call_main}"
+ ebegin "readahead(2): ${f}"
+ /sbin/readahead-list ${f}
+ eend $?
+}
+
+# vim: ts=4 sw=4
diff --git a/sys-apps/readahead-list/files/init.d-readahead-list-early b/sys-apps/readahead-list/files/init.d-readahead-list-early
new file mode 100644
index 000000000000..d6a936febb6c
--- /dev/null
+++ b/sys-apps/readahead-list/files/init.d-readahead-list-early
@@ -0,0 +1,23 @@
+#!/sbin/runscript
+# Copyright 2005 Robin H. Johnson <robbat2@orbis-terrarum.net>
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+
+depend() {
+ after checkroot
+ # this should start as early as possible
+ # we can't do 'before *' as that breaks it
+ before hostname modules domainname crypto-loop checkfs localmount
+}
+
+start() {
+ # force reading
+ source /etc/conf.d/readahead-list
+ f="${READAHEAD_LIST_call_early}"
+ ebegin "readahead(2): ${f}"
+ /sbin/readahead-list ${f}
+ eend $?
+}
+
+# vim: ts=4 sw=4
diff --git a/sys-apps/readahead-list/files/readahead-list-1.20060421.1016-gcc-4.3.patch b/sys-apps/readahead-list/files/readahead-list-1.20060421.1016-gcc-4.3.patch
new file mode 100644
index 000000000000..6264bbad9525
--- /dev/null
+++ b/sys-apps/readahead-list/files/readahead-list-1.20060421.1016-gcc-4.3.patch
@@ -0,0 +1,10 @@
+--- src/filelist-order.cxx
++++ src/filelist-order.cxx
+@@ -19,6 +19,7 @@
+ #include <iostream>
+ #include <fstream>
+ #include <vector>
++#include <cstdlib>
+
+ #include <assert.h>
+ #include <string.h>
diff --git a/sys-apps/readahead-list/metadata.xml b/sys-apps/readahead-list/metadata.xml
new file mode 100644
index 000000000000..c530161e6cdb
--- /dev/null
+++ b/sys-apps/readahead-list/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>base-system</herd>
+<maintainer>
+ <email>robbat2@gentoo.org</email>
+ <description>Upstream author as well as maintainer for Gentoo.</description>
+</maintainer>
+</pkgmetadata>
diff --git a/sys-apps/readahead-list/readahead-list-1.20060421.1016-r1.ebuild b/sys-apps/readahead-list/readahead-list-1.20060421.1016-r1.ebuild
new file mode 100644
index 000000000000..5f5d38b9e3bf
--- /dev/null
+++ b/sys-apps/readahead-list/readahead-list-1.20060421.1016-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit base
+
+DESCRIPTION="Preloads files into the page cache to accelerate program loading"
+HOMEPAGE="http://www.orbis-terrarum.net"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ virtual/os-headers"
+
+PATCHES=( "${FILESDIR}/${P}-gcc-4.3.patch" )
+
+src_compile() {
+ econf --sbindir=/sbin || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ # init scripts
+ #cd "${S}/contrib/init/gentoo/"
+ newinitd "${FILESDIR}"/init.d-readahead-list readahead-list
+ newinitd "${FILESDIR}"/init.d-readahead-list-early readahead-list-early
+ newconfd "${FILESDIR}"/conf.d-readahead-list readahead-list
+
+ # default config
+ insinto /etc/readahead-list
+ cd "${S}/contrib/data"
+ newins readahead.runlevel-default.list runlevel-default
+ newins readahead.runlevel-boot.list runlevel-boot
+ newins readahead._sbin_rc.list exec_sbin_rc
+
+ # docs
+ cd "${S}"
+ dodoc README
+ if use doc; then
+ docinto scripts
+ dodoc contrib/scripts/*
+ fi
+ # clean up a bit
+ find "${D}/usr/share/doc/${PF}/" -type f -name 'Makefile*' -exec rm -f \{\} \;
+}
+
+pkg_postinst() {
+ einfo "You should add readahead-list to your runlevels:"
+ einfo " rc-update add readahead-list-early boot"
+ einfo " rc-update add readahead-list boot"
+ einfo "Also consider customizing the lists in /etc/readahead-list"
+ einfo "for maximum performance gain."
+}
diff --git a/sys-apps/readahead-list/readahead-list-1.20060421.1016.ebuild b/sys-apps/readahead-list/readahead-list-1.20060421.1016.ebuild
new file mode 100644
index 000000000000..8b39923d5ca9
--- /dev/null
+++ b/sys-apps/readahead-list/readahead-list-1.20060421.1016.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit base
+
+DESCRIPTION="Preloads files into the page cache to accelerate program loading"
+HOMEPAGE="http://www.orbis-terrarum.net"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="doc"
+
+# I'm not entirely certain about this
+# need to check if other libc variants provide readahead(2)
+RDEPEND=""
+DEPEND="${RDEPEND}
+ virtual/os-headers"
+
+PATCHES=( "${FILESDIR}/${P}-gcc-4.3.patch" )
+
+src_compile() {
+ econf --sbindir=/sbin || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ # init scripts
+ cd "${S}/contrib/init/gentoo/"
+ newinitd init.d-readahead-list readahead-list
+ newinitd init.d-readahead-list-early readahead-list-early
+ newconfd conf.d-readahead-list readahead-list
+
+ # default config
+ insinto /etc/readahead-list
+ cd "${S}/contrib/data"
+ newins readahead.runlevel-default.list runlevel-default
+ newins readahead.runlevel-boot.list runlevel-boot
+ newins readahead._sbin_rc.list exec_sbin_rc
+
+ # docs
+ cd "${S}"
+ dodoc README
+ if use doc; then
+ docinto scripts
+ dodoc contrib/scripts/*
+ fi
+ # clean up a bit
+ find "${D}/usr/share/doc/${PF}/" -type f -name 'Makefile*' -exec rm -f \{} \;
+}
+
+pkg_postinst() {
+ einfo "You should add readahead-list to your runlevels:"
+ einfo " rc-update add readahead-list-early boot"
+ einfo " rc-update add readahead-list boot"
+ einfo "Also consider customizing the lists in /etc/readahead-list"
+ einfo "for maximum performance gain."
+}