summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/rng-tools/files/rng-tools-6.16-c99.patch')
-rw-r--r--sys-apps/rng-tools/files/rng-tools-6.16-c99.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/sys-apps/rng-tools/files/rng-tools-6.16-c99.patch b/sys-apps/rng-tools/files/rng-tools-6.16-c99.patch
new file mode 100644
index 000000000000..dad35eeed1ff
--- /dev/null
+++ b/sys-apps/rng-tools/files/rng-tools-6.16-c99.patch
@@ -0,0 +1,22 @@
+https://bugs.gentoo.org/919399
+https://github.com/nhorman/rng-tools/pull/205
+
+From 593e326815ba7ee820ee2f0a3c45279282f07c34 Mon Sep 17 00:00:00 2001
+From: Florian Weimer <fweimer@redhat.com>
+Date: Tue, 19 Dec 2023 10:32:11 +0100
+Subject: [PATCH] configure: Fix m4 quoting issue in libargp probe
+
+Without the surrounding [], m4 drops the inner [], treating, argv[] as
+argv. This results in an incorrect argument type for argp_parse,
+causing the probe to fail with future compilers due to type error.
+--- a/configure.ac
++++ b/configure.ac
+@@ -196,7 +196,7 @@ AS_IF(
+ AC_LINK_IFELSE(
+ [AC_LANG_PROGRAM(
+ [#include <argp.h>],
+- [int argc=1; char *argv[]={"test"}; argp_parse(0,argc,argv,0,0,0); return 0;]
++ [[int argc=1; char *argv[]={"test"}; argp_parse(0,argc,argv,0,0,0); return 0;]]
+ )],
+ [need_libargp=no],
+ [need_libargp=yes