summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/s6-rc/s6-rc-0.5.3.2.ebuild')
-rw-r--r--sys-apps/s6-rc/s6-rc-0.5.3.2.ebuild13
1 files changed, 12 insertions, 1 deletions
diff --git a/sys-apps/s6-rc/s6-rc-0.5.3.2.ebuild b/sys-apps/s6-rc/s6-rc-0.5.3.2.ebuild
index 9950834606c2..47fe23696e6f 100644
--- a/sys-apps/s6-rc/s6-rc-0.5.3.2.ebuild
+++ b/sys-apps/s6-rc/s6-rc-0.5.3.2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -49,3 +49,14 @@ src_configure() {
econf "${myconf[@]}"
}
+
+pkg_postinst() {
+ for ver in ${REPLACING_VERSIONS}; do
+ if ver_test "${ver}" -ge "0.5.4.0"; then
+ elog "Location of helper utilities was changed from /usr/libexec to /lib/s6 in"
+ elog "version 0.5.4.0. It is necessary to recompile and update s6-rc database and"
+ elog "restart s6rc-oneshot-runner service because you are downgrading from newer"
+ elog "version."
+ fi
+ done
+}