summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/superiotool/superiotool-99999999.ebuild')
-rw-r--r--sys-apps/superiotool/superiotool-99999999.ebuild16
1 files changed, 6 insertions, 10 deletions
diff --git a/sys-apps/superiotool/superiotool-99999999.ebuild b/sys-apps/superiotool/superiotool-99999999.ebuild
index 9cd57fadcfca..83db272b25ab 100644
--- a/sys-apps/superiotool/superiotool-99999999.ebuild
+++ b/sys-apps/superiotool/superiotool-99999999.ebuild
@@ -1,14 +1,13 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
+EAPI=6
-inherit toolchain-funcs eutils
+inherit toolchain-funcs
-if [[ ${PV} == "99999999" ]] ; then
+if [[ ${PV} == *99999999 ]] ; then
ESVN_REPO_URI="svn://coreboot.org/coreboot/trunk/util/${PN}"
inherit subversion
- SRC_URI=""
else
SRC_URI="mirror://gentoo/${P}.tar.xz"
KEYWORDS="~amd64 ~x86"
@@ -26,6 +25,8 @@ DEPEND="${RDEPEND}
app-arch/xz-utils"
src_prepare() {
+ default
+
sed -i \
-e 's:-Werror ::' \
-e 's:-O2 ::' \
@@ -40,8 +41,3 @@ src_compile() {
CC="$(tc-getCC)" \
SVNDEF="-D'SUPERIOTOOL_VERSION=\"${ESVN_WC_REVISION}\"'"
}
-
-src_install() {
- emake install DESTDIR="${D}"
- dodoc README
-}