summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/system-monitoring-center')
-rw-r--r--sys-apps/system-monitoring-center/Manifest1
-rw-r--r--sys-apps/system-monitoring-center/system-monitoring-center-2.17.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/sys-apps/system-monitoring-center/Manifest b/sys-apps/system-monitoring-center/Manifest
index 227e5bbedfe8..14bb2a6b3713 100644
--- a/sys-apps/system-monitoring-center/Manifest
+++ b/sys-apps/system-monitoring-center/Manifest
@@ -1,2 +1,3 @@
DIST system-monitoring-center-2.14.0.tar.gz 550257 BLAKE2B 3ea3b392c08bcbdba960f03b00a65dab94e1911b53f17fe38ccbd9a7c59f38094a928184a0db488fcd7c60d80ff31a7e59e2bfdf0efda43035cfd59b0f3e38e1 SHA512 4453709b1ef937ba8582ab76b25573f9e4975f4f905284c273dc3490ff2348800fb1c6ed3bca96db4952fc9c3b7fae2fd278ed945fe5c14f8dcfcec410eca415
DIST system-monitoring-center-2.16.1.tar.gz 539174 BLAKE2B eca36d31a5f42632611e2dec78afe94d109522e6028331587760037cdf05e334369a7491ba703262c1fd1d45817da1041a5214e1ec779d55bdf0c19c4995bfd6 SHA512 e30e3abf00d6d3612b6406d6f4439bc0f0d384dddd4ddc2059193cb06f3968bfe64d93b46c38edff4fd290a9b39b3f6d3f595ee3f3c04b125db3e41525a01205
+DIST system-monitoring-center-2.17.1.tar.gz 533980 BLAKE2B 242dbc8d98384bce191aa27d91087166af2048d862fa82d33e0fd6b67d3214897612480d91c00eea5ac8a30dfacea29666b5959422f85d8ba323a5cb19ecb460 SHA512 28a13da3d1c5a3496c8a138a9dae4402cfce89bd2ff67748c6ce9da4c2d9d616c2bfab7b2c80dfbd7220c3c940b4078fbde835959c72a6ead392bbb25c864257
diff --git a/sys-apps/system-monitoring-center/system-monitoring-center-2.17.1.ebuild b/sys-apps/system-monitoring-center/system-monitoring-center-2.17.1.ebuild
new file mode 100644
index 000000000000..1274d6fa96c9
--- /dev/null
+++ b/sys-apps/system-monitoring-center/system-monitoring-center-2.17.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit meson python-single-r1 xdg
+
+DESCRIPTION="Multi-featured system monitor GUI written in Python"
+HOMEPAGE="https://github.com/hakandundar34coding/system-monitoring-center/"
+SRC_URI="https://github.com/hakandundar34coding/${PN}/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ gui-libs/gtk:4[introspection]
+ sys-apps/dmidecode
+ sys-apps/hwdata
+ $(python_gen_cond_dep '
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+"
+
+src_install() {
+ meson_src_install
+ python_optimize "${ED}"/usr/share/${PN}
+
+ mv "${ED}"/usr/share/appdata "${ED}"/usr/share/metainfo || die
+}