summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/systemd-tmpfiles/systemd-tmpfiles-246.ebuild')
-rw-r--r--sys-apps/systemd-tmpfiles/systemd-tmpfiles-246.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/sys-apps/systemd-tmpfiles/systemd-tmpfiles-246.ebuild b/sys-apps/systemd-tmpfiles/systemd-tmpfiles-246.ebuild
index 5ca307a1443d..7585b1486ec6 100644
--- a/sys-apps/systemd-tmpfiles/systemd-tmpfiles-246.ebuild
+++ b/sys-apps/systemd-tmpfiles/systemd-tmpfiles-246.ebuild
@@ -8,7 +8,8 @@ inherit meson
DESCRIPTION="Creates, deletes and cleans up volatile and temporary files and directories"
HOMEPAGE="https://www.freedesktop.org/wiki/Software/systemd"
-SRC_URI="https://github.com/systemd/systemd/archive/v${PV}.tar.gz -> systemd-${PV}.tar.gz"
+SRC_URI="https://github.com/systemd/systemd/archive/v${PV}.tar.gz -> systemd-${PV}.tar.gz
+ elibc_musl? ( https://dev.gentoo.org/~gyakovlev/distfiles/${P}-musl.tar.xz )"
LICENSE="BSD-2 GPL-2 LGPL-2.1 MIT public-domain"
SLOT="0"
@@ -39,6 +40,13 @@ BDEPEND="
S="${WORKDIR}/systemd-${PV}"
+src_prepare() {
+ # musl patchset from:
+ # http://cgit.openembedded.org/openembedded-core/tree/meta/recipes-core/systemd/systemd
+ use elibc_musl && eapply "${WORKDIR}/${P}-musl"
+ default
+}
+
src_configure() {
# disable everything until configure says "enabled features: ACL, tmpfiles"
local systemd_disable_options=(