summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/systemd-utils/systemd-utils-254.8.ebuild')
-rw-r--r--sys-apps/systemd-utils/systemd-utils-254.8.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/sys-apps/systemd-utils/systemd-utils-254.8.ebuild b/sys-apps/systemd-utils/systemd-utils-254.8.ebuild
index af0e5dfe3c6a..b73e1d640a89 100644
--- a/sys-apps/systemd-utils/systemd-utils-254.8.ebuild
+++ b/sys-apps/systemd-utils/systemd-utils-254.8.ebuild
@@ -446,8 +446,6 @@ multilib_src_install() {
if use kernel-install; then
dobin kernel-install
doman man/kernel-install.8
- # copy the default set of plugins
- cp "${S}/src/kernel-install/"*.install src/kernel-install || die
exeinto usr/lib/kernel/install.d
doexe src/kernel-install/*.install
fi
@@ -504,12 +502,14 @@ multilib_src_install_all() {
einstalldocs
if use boot; then
into /usr
- exeinto usr/lib/kernel/install.d
- doexe src/kernel-install/*.install
dobashcomp shell-completion/bash/bootctl
insinto /usr/share/zsh/site-functions
doins shell-completion/zsh/{_bootctl,_kernel-install}
fi
+ if use kernel-install; then
+ exeinto usr/lib/kernel/install.d
+ doexe src/kernel-install/*.install
+ fi
if use tmpfiles; then
doinitd "${FILESDIR}"/systemd-tmpfiles-setup
doinitd "${FILESDIR}"/systemd-tmpfiles-setup-dev