summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/systemd/systemd-254.7-r1.ebuild')
-rw-r--r--sys-apps/systemd/systemd-254.7-r1.ebuild11
1 files changed, 10 insertions, 1 deletions
diff --git a/sys-apps/systemd/systemd-254.7-r1.ebuild b/sys-apps/systemd/systemd-254.7-r1.ebuild
index 89798cf92eff..a3b0cb5166c9 100644
--- a/sys-apps/systemd/systemd-254.7-r1.ebuild
+++ b/sys-apps/systemd/systemd-254.7-r1.ebuild
@@ -26,7 +26,7 @@ else
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
fi
-inherit bash-completion-r1 linux-info meson-multilib pam python-single-r1
+inherit bash-completion-r1 linux-info meson-multilib optfeature pam python-single-r1
inherit secureboot systemd toolchain-funcs udev usr-ldscript
DESCRIPTION="System and service manager for Linux"
@@ -520,6 +520,15 @@ pkg_postinst() {
eerror "systemd again."
eerror
fi
+
+ if use boot; then
+ optfeature "automatically installing the kernels in systemd-boot's native layout and updating the bootloader configuration" \
+ "sys-kernel/installkernel[systemd-boot]"
+ fi
+ if use ukify; then
+ optfeature "automatically generating an unified kernel image on each kernel installation" \
+ "sys-kernel/installkernel[ukify]"
+ fi
}
pkg_prerm() {