summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/usb_modeswitch')
-rw-r--r--sys-apps/usb_modeswitch/files/usb_modeswitch.sh-tmpdir.patch18
-rw-r--r--sys-apps/usb_modeswitch/usb_modeswitch-2.4.0-r1.ebuild (renamed from sys-apps/usb_modeswitch/usb_modeswitch-2.4.0.ebuild)3
2 files changed, 20 insertions, 1 deletions
diff --git a/sys-apps/usb_modeswitch/files/usb_modeswitch.sh-tmpdir.patch b/sys-apps/usb_modeswitch/files/usb_modeswitch.sh-tmpdir.patch
new file mode 100644
index 000000000000..5039d44da1fd
--- /dev/null
+++ b/sys-apps/usb_modeswitch/files/usb_modeswitch.sh-tmpdir.patch
@@ -0,0 +1,18 @@
+Script that this patch modifies and usb_modeswitch_dispatcher Tcl script
+that is being called by it both need a writable temporary directory which
+is a problematic requirement for example if usb_modeswitch is triggered
+by a module loaded during system startup.
+Fortunately, /run is available very early at boot so let's redirect them
+there instead.
+
+--- a/usb_modeswitch.sh 2016-11-29 17:29:47.000000000 +0100
++++ b/usb_modeswitch.sh 2016-11-30 01:11:51.747993839 +0100
+@@ -17,6 +17,8 @@
+ return 0
+ }
+
++export TMPDIR=/run
++
+ if [ $(expr "$1" : "--.*") ]; then
+ p_id=$4
+ if [ -z $p_id ]; then
diff --git a/sys-apps/usb_modeswitch/usb_modeswitch-2.4.0.ebuild b/sys-apps/usb_modeswitch/usb_modeswitch-2.4.0-r1.ebuild
index ceb9bfd3b851..74132f36d153 100644
--- a/sys-apps/usb_modeswitch/usb_modeswitch-2.4.0.ebuild
+++ b/sys-apps/usb_modeswitch/usb_modeswitch-2.4.0-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
@@ -37,6 +37,7 @@ CONFIG_CHECK="~USB_SERIAL"
src_prepare() {
sed -i -e '/install.*BIN/s:-s::' Makefile || die
+ epatch "${FILESDIR}/usb_modeswitch.sh-tmpdir.patch"
}
src_compile() {