summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/xdg-desktop-portal-gtk/xdg-desktop-portal-gtk-1.8.0.ebuild')
-rw-r--r--sys-apps/xdg-desktop-portal-gtk/xdg-desktop-portal-gtk-1.8.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/sys-apps/xdg-desktop-portal-gtk/xdg-desktop-portal-gtk-1.8.0.ebuild b/sys-apps/xdg-desktop-portal-gtk/xdg-desktop-portal-gtk-1.8.0.ebuild
new file mode 100644
index 000000000000..ed07582361da
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal-gtk/xdg-desktop-portal-gtk-1.8.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools systemd
+
+MY_PV="${PV//_pre*}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="portal backend implementation that is using GTK+ and various pieces of GNOME"
+HOMEPAGE="https://flatpak.org/ https://github.com/flatpak/xdg-desktop-portal-gtk"
+SRC_URI="https://github.com/flatpak/${PN}/releases/download/${MY_PV}/${MY_P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS=""
+IUSE="wayland X"
+
+BDEPEND="
+ dev-util/gdbus-codegen
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+DEPEND="
+ dev-libs/glib:2
+ gnome-base/gnome-desktop:3=
+ media-libs/fontconfig
+ sys-apps/dbus
+ >=sys-apps/xdg-desktop-portal-1.7
+ x11-libs/cairo[X?]
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3[wayland?,X?]
+"
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ local myeconfargs=(
+ --with-systemduserunitdir="$(systemd_get_userunitdir)"
+ )
+
+ econf "${myeconfargs[@]}"
+}