summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/xdg-desktop-portal-gtk')
-rw-r--r--sys-apps/xdg-desktop-portal-gtk/Manifest1
-rw-r--r--sys-apps/xdg-desktop-portal-gtk/xdg-desktop-portal-gtk-1.14.1.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/sys-apps/xdg-desktop-portal-gtk/Manifest b/sys-apps/xdg-desktop-portal-gtk/Manifest
index e52338abe957..7220165a1791 100644
--- a/sys-apps/xdg-desktop-portal-gtk/Manifest
+++ b/sys-apps/xdg-desktop-portal-gtk/Manifest
@@ -1 +1,2 @@
DIST xdg-desktop-portal-gtk-1.14.0.tar.xz 381316 BLAKE2B 73a1e1d9944c4776ef2ebff33b26559767aad10784e9518690d31575a6216014bd0c518bde9a3b4e92d6a7edbf1aaa3510d669a025b7574c4df978f7c24b83ac SHA512 b0ba54e1ddbdfbd22b8b31bf4ece261dc0beba303e642f10afc72659dd5477438a30688c9d018e3d1ed2adbc053ddf4e3a2d70de8cac03d9519355772862fafc
+DIST xdg-desktop-portal-gtk-1.14.1.tar.xz 393964 BLAKE2B fd7fb960a19a13ad722b3db6e00a81e737c25434a6c4f70b97ad6cb2f9e01a06e9dc563f0e61f496260275854404b006cf4b36df56cc967202def6ca4bf0c8a0 SHA512 d8b487e8fc7d8c1f0f41eb3ee28377b2f77af9c65569b5dbaee785ae40c163929da8b13b39b032e25631515cb8e7218129c8bbffe25692e85c7b8e9269024325
diff --git a/sys-apps/xdg-desktop-portal-gtk/xdg-desktop-portal-gtk-1.14.1.ebuild b/sys-apps/xdg-desktop-portal-gtk/xdg-desktop-portal-gtk-1.14.1.ebuild
new file mode 100644
index 000000000000..011da45afd39
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal-gtk/xdg-desktop-portal-gtk-1.14.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd
+
+MY_PV="${PV//_pre*}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="Backend implementation for xdg-desktop-portal using GTK+"
+HOMEPAGE="https://flatpak.org/ https://github.com/flatpak/xdg-desktop-portal-gtk"
+SRC_URI="https://github.com/flatpak/${PN}/releases/download/${MY_PV}/${MY_P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="wayland X"
+
+BDEPEND="
+ dev-util/gdbus-codegen
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+DEPEND="
+ dev-libs/glib:2
+ media-libs/fontconfig
+ sys-apps/dbus
+ >=sys-apps/xdg-desktop-portal-1.14.0
+ x11-libs/cairo[X?]
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3[wayland?,X?]
+"
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ # As done in Fedora:
+ # All backends that are disabled are instead provided by
+ # xdg-desktop-portal-gnome to keep this package free of GNOME dependencies.
+ # The appchooser and settings backends are enabled for non-GNOME GTK
+ # applications.
+ local myeconfargs=(
+ --with-systemduserunitdir="$(systemd_get_userunitdir)"
+ --enable-appchooser
+ --enable-settings
+ --disable-background
+ --disable-lockdown
+ --disable-screencast
+ --disable-screenshot
+ --disable-wallpaper
+ )
+
+ econf "${myeconfargs[@]}"
+}