summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/xdg-desktop-portal')
-rw-r--r--sys-apps/xdg-desktop-portal/Manifest1
-rw-r--r--sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.14.5.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/sys-apps/xdg-desktop-portal/Manifest b/sys-apps/xdg-desktop-portal/Manifest
index 915e9e332aa2..c92c3fc2895c 100644
--- a/sys-apps/xdg-desktop-portal/Manifest
+++ b/sys-apps/xdg-desktop-portal/Manifest
@@ -1 +1,2 @@
DIST xdg-desktop-portal-1.14.4.tar.xz 510492 BLAKE2B 32f71cbc74d6bb3010e31172972dd7bfc4c982691ef55f66c29d5cf4aa2abeed816f890800691e898f739c2c7aa13db1e04f322c89ce30e9ac8a69b87435a448 SHA512 23fa4f9fdf39f22d6eaa4f6020db5f81d272b85fe6051467c5e28a752c65b18a9b540fafe5b27725fafa29dffefcd113d873928cd78e3658895cd24d96b82f73
+DIST xdg-desktop-portal-1.14.5.tar.xz 514880 BLAKE2B ec470a54c3336c73af1cee1c589726884dc5607d7af6e68d4ea8653706fb5a33aa2bf8e45b432d4954c49fa313d62f43f658efb0222c2c706cd377bdbf74c5b7 SHA512 5ce108ca5ef7bffe292d2ac39f22e555c56b02ec1635716bb1fb71aebf9146aa1fdda1392a6c8e2c9e61f1789445eb642b91cf8d25d3aa3f196a368026aeb984
diff --git a/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.14.5.ebuild b/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.14.5.ebuild
new file mode 100644
index 000000000000..b3c3088512f7
--- /dev/null
+++ b/sys-apps/xdg-desktop-portal/xdg-desktop-portal-1.14.5.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd
+
+DESCRIPTION="Desktop integration portal"
+HOMEPAGE="https://flatpak.org/ https://github.com/flatpak/xdg-desktop-portal"
+SRC_URI="https://github.com/flatpak/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="geolocation screencast systemd"
+
+DEPEND="
+ >=dev-libs/glib-2.66:2
+ dev-libs/json-glib
+ >=sys-fs/fuse-3.10.0:3
+ x11-libs/gdk-pixbuf
+ geolocation? ( >=app-misc/geoclue-2.5.3:2.0 )
+ screencast? ( >=media-video/pipewire-0.3:= )
+ systemd? ( sys-apps/systemd )
+"
+RDEPEND="${DEPEND}
+ sys-apps/dbus
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myeconfargs=(
+ --disable-docbook-docs # requires flatpak
+ --disable-libportal # not packaged
+ --with-systemduserunitdir="$(systemd_get_userunitdir)"
+ $(use_enable geolocation geoclue)
+ $(use_enable screencast pipewire)
+ $(use_with systemd)
+ )
+ econf "${myeconfargs[@]}"
+}