summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/s6-rc/Manifest1
-rw-r--r--sys-apps/s6-rc/s6-rc-0.5.3.2.ebuild62
2 files changed, 0 insertions, 63 deletions
diff --git a/sys-apps/s6-rc/Manifest b/sys-apps/s6-rc/Manifest
index 971a8e7a1c22..2dfed362bf6c 100644
--- a/sys-apps/s6-rc/Manifest
+++ b/sys-apps/s6-rc/Manifest
@@ -1,2 +1 @@
-DIST s6-rc-0.5.3.2.tar.gz 99249 BLAKE2B 5719823edf9e9bece6a3efdb5072c4555fc796c48144a0d1da52c609aef8d7437afc9c30924636891a829a307c30017a85140644fb7836b380adb8afbd49b35b SHA512 72963b2aa8e338503918d063102653d392cbd701823e35f87b45d9777fd512f7ad49ab47b94df0f9e5ef50a0dad5162f6f3526fa77dfaa3afb48ad8db4097051
DIST s6-rc-0.5.4.1.tar.gz 101078 BLAKE2B d85a194712ab63369cb71cbe4c59efd8cbe507a5e74c6bdb1bbe9a0e9123b8b1179850a8abdb0dbc67ef3c09764c9a6fb11c5b366590ecf4922b0d5a0115bc14 SHA512 6b61df9fa1d9bd24430bab4c11bfba009ca79c62a32dd2db3b79a1057645da9f92db4058c66c35bb068d805d958bfdf024399d240559dfdee62f9a6a30cf2086
diff --git a/sys-apps/s6-rc/s6-rc-0.5.3.2.ebuild b/sys-apps/s6-rc/s6-rc-0.5.3.2.ebuild
deleted file mode 100644
index 47fe23696e6f..000000000000
--- a/sys-apps/s6-rc/s6-rc-0.5.3.2.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit toolchain-funcs
-
-DESCRIPTION="Service manager for the s6 supervision suite"
-HOMEPAGE="https://www.skarnet.org/software/s6-rc/"
-SRC_URI="https://www.skarnet.org/software/${PN}/${P}.tar.gz"
-
-LICENSE="ISC"
-SLOT="0/$(ver_cut 1-2)"
-KEYWORDS="amd64 arm x86"
-
-RDEPEND="dev-lang/execline:=
- dev-libs/skalibs:=
- sys-apps/s6:=[execline]
-"
-DEPEND="${RDEPEND}"
-
-HTML_DOCS=( doc/. )
-
-src_prepare() {
- default
-
- # Avoid QA warning for LDFLAGS addition
- sed -i -e 's/.*-Wl,--hash-style=both$/:/' configure || die
-
- sed -i -e '/AR := /d' -e '/RANLIB := /d' Makefile || die
-}
-
-src_configure() {
- tc-export AR CC RANLIB
-
- local myconf=(
- --bindir=/bin
- --dynlibdir=/usr/$(get_libdir)
- --libdir=/usr/$(get_libdir)/${PN}
- --with-dynlib=/usr/$(get_libdir)
- --with-lib=/usr/$(get_libdir)/execline
- --with-lib=/usr/$(get_libdir)/s6
- --with-lib=/usr/$(get_libdir)/skalibs
- --with-sysdeps=/usr/$(get_libdir)/skalibs
- --enable-shared
- --disable-allstatic
- --disable-static-libc
- )
-
- econf "${myconf[@]}"
-}
-
-pkg_postinst() {
- for ver in ${REPLACING_VERSIONS}; do
- if ver_test "${ver}" -ge "0.5.4.0"; then
- elog "Location of helper utilities was changed from /usr/libexec to /lib/s6 in"
- elog "version 0.5.4.0. It is necessary to recompile and update s6-rc database and"
- elog "restart s6rc-oneshot-runner service because you are downgrading from newer"
- elog "version."
- fi
- done
-}