summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/gentoo-systemd-integration/Manifest1
-rw-r--r--sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9.ebuild30
-rw-r--r--sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9999.ebuild12
3 files changed, 36 insertions, 7 deletions
diff --git a/sys-apps/gentoo-systemd-integration/Manifest b/sys-apps/gentoo-systemd-integration/Manifest
index 16f6be65ab64..c79b502012d8 100644
--- a/sys-apps/gentoo-systemd-integration/Manifest
+++ b/sys-apps/gentoo-systemd-integration/Manifest
@@ -1,2 +1,3 @@
DIST gentoo-systemd-integration-7.tar.gz 64243 BLAKE2B 389c6627af6eca9b4a0854d35751a8cb45cdb2795c7b621e96e9d5bcc13a80fe1cb109c0cb2bfd9d33f7642fd08198a0afbd5b4e5956ea6ba8dc89cf4635d9c0 SHA512 cd47caa01d73da57998b6b37d89cbeb53fa722c7f4a31bb03d03762350490cde1db3ce06090df6b6ff25c1cafb40f6c2186efbd52156ebc6d078b4a59d6fef52
DIST gentoo-systemd-integration-8.tar.bz2 53734 BLAKE2B 711f1f6603fa40e81fe32809a32f61486ab068b1f636502ac36d58e4c204b5f0d46f51a6624f134a457f246b520614213cf45cc5397de769b315e01e32720bcf SHA512 373892ca9ae8845673f9ddad74e0be0b71af944e109adf0d2ce8e54a9c24ffff5e90cfa92e74b7abc1e7d7b1598404258b90b549697bde28a1025a2d974e991f
+DIST gentoo-systemd-integration-9.tar.gz 65696 BLAKE2B 7d2105e37ff53d48e312b78a971f16124df1d3a1f99ae37eb757e4be31663eee15ba1a9fb31ef31250c79f902f7a00e1de84030f3fb67e41ab2243d58deabcb6 SHA512 e4810e74c713793f1e5aca7f025780c32e8f0fe404bf74b65263bfaeff1ae1398551fdff7de37a4050f0e48d5e0b90525217f5b3caa18111ab1981f57f41fc18
diff --git a/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9.ebuild b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9.ebuild
new file mode 100644
index 000000000000..7983540e7260
--- /dev/null
+++ b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gentoo-systemd-integration.git"
+ inherit autotools git-r3
+else
+ SRC_URI="https://dev.gentoo.org/~floppym/dist/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+fi
+
+DESCRIPTION="systemd integration files for Gentoo"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Systemd"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=sys-apps/systemd-207
+ !sys-fs/eudev
+ !sys-fs/udev"
+DEPEND=">=sys-apps/systemd-207"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+ [[ ${PV} != 9999 ]] || eautoreconf
+}
diff --git a/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9999.ebuild b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9999.ebuild
index 37315de4274a..7983540e7260 100644
--- a/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9999.ebuild
+++ b/sys-apps/gentoo-systemd-integration/gentoo-systemd-integration-9999.ebuild
@@ -1,18 +1,16 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gentoo-systemd-integration.git"
inherit autotools git-r3
else
SRC_URI="https://dev.gentoo.org/~floppym/dist/${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
fi
-inherit systemd
-
DESCRIPTION="systemd integration files for Gentoo"
HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Systemd"
@@ -23,8 +21,8 @@ IUSE=""
RDEPEND=">=sys-apps/systemd-207
!sys-fs/eudev
!sys-fs/udev"
-DEPEND=">=sys-apps/systemd-207
- virtual/pkgconfig"
+DEPEND=">=sys-apps/systemd-207"
+BDEPEND="virtual/pkgconfig"
src_prepare() {
default