summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps')
-rw-r--r--sys-apps/pcsc-tools/Manifest1
-rw-r--r--sys-apps/pcsc-tools/pcsc-tools-1.7.0.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/sys-apps/pcsc-tools/Manifest b/sys-apps/pcsc-tools/Manifest
index 2575cb660f5f..5c459fcabd96 100644
--- a/sys-apps/pcsc-tools/Manifest
+++ b/sys-apps/pcsc-tools/Manifest
@@ -1 +1,2 @@
DIST pcsc-tools-1.6.2.tar.bz2 320182 BLAKE2B 88a76f4120a183df909ce9d189e38e51897080839ebe7ca85aa4447a441363e6917ddb1c5e6c0e881c8792078700676ad1cfe24609957a4fef54374d5be824a4 SHA512 20104baefa7928a86d21cee49d045cc35b8e74fec5be79ba5608ae046a110096efae96768d281e0f1350f71a889f89c675336d8264c75f8423369a49c03b42a8
+DIST pcsc-tools-1.7.0.tar.bz2 360064 BLAKE2B e9f22e13600e40c488720844c6e93d90e8a5dd0e085b3b5245096dbc390e5978c9ff17c9cf5c34cf82f8d0cfbaf9b3d44a25b331439c5e09bf7b075d769f7a36 SHA512 8de48526306b23e9dea6d99d29ec5f1230e3959bfe82a4d1b7d65f9767369757a1f440ceca7debeba68a8492607c91d0dcf7bec366cd213f00be45a5ef018d67
diff --git a/sys-apps/pcsc-tools/pcsc-tools-1.7.0.ebuild b/sys-apps/pcsc-tools/pcsc-tools-1.7.0.ebuild
new file mode 100644
index 000000000000..b7ebde02ddb1
--- /dev/null
+++ b/sys-apps/pcsc-tools/pcsc-tools-1.7.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop toolchain-funcs xdg-utils
+
+DESCRIPTION="PC/SC Architecture smartcard tools"
+HOMEPAGE="https://pcsc-tools.apdu.fr/ https://github.com/LudovicRousseau/pcsc-tools"
+SRC_URI="https://pcsc-tools.apdu.fr/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="gui network-cron nls"
+
+DEPEND=">=sys-apps/pcsc-lite-1.4.14"
+RDEPEND="
+ ${DEPEND}
+ dev-perl/pcsc-perl
+ gui? ( dev-perl/Gtk3 )
+"
+BDEPEND="
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+src_configure() {
+ econf $(use_enable nls gettext)
+}
+
+src_compile() {
+ # explicitly only build the pcsc_scan application, or the man
+ # pages will be gzipped first, and then unpacked.
+ emake pcsc_scan CC="$(tc-getCC)"
+}
+
+src_install() {
+ einstalldocs
+
+ # install manually, makes it much easier since the Makefile
+ # requires fiddling with
+ dobin ATR_analysis scriptor pcsc_scan
+ doman pcsc_scan.1 scriptor.1p ATR_analysis.1p
+
+ if use gui; then
+ domenu gscriptor.desktop
+ dobin gscriptor
+ doman gscriptor.1p
+ fi
+
+ if use network-cron ; then
+ exeinto /etc/cron.monthly
+ newexe "${FILESDIR}"/smartcard.cron update-smartcard_list
+ fi
+
+ insinto /usr/share/pcsc
+ doins smartcard_list.txt
+}
+
+pkg_postinst() {
+ use gui && xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}