summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/docker_auth/docker_auth-1.1.ebuild')
-rw-r--r--sys-auth/docker_auth/docker_auth-1.1.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/sys-auth/docker_auth/docker_auth-1.1.ebuild b/sys-auth/docker_auth/docker_auth-1.1.ebuild
index 6b9451670378..e535d4d420a5 100644
--- a/sys-auth/docker_auth/docker_auth-1.1.ebuild
+++ b/sys-auth/docker_auth/docker_auth-1.1.ebuild
@@ -33,6 +33,9 @@ LICENSE="Apache-2.0"
SLOT="0"
IUSE=""
+DEPEND="dev-go/go-crypto:=
+ dev-go/go-sys:="
+
_golang-include-src() {
local VENDORPN=$1 TARBALL=$2
mkdir -p "${WORKDIR}/${P}/src/${VENDORPN}" || die
@@ -85,5 +88,10 @@ src_install() {
insinto /etc/docker_auth/
newins examples/reference.yml config.yml.example
dobin auth_server/bin/auth_server
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/${PN}.logrotated ${PN}
+ keepdir /var/log/docker_auth
popd || die
}