summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/elogind')
-rw-r--r--sys-auth/elogind/elogind-246.9.1-r1.ebuild (renamed from sys-auth/elogind/elogind-246.9.1.ebuild)2
-rw-r--r--sys-auth/elogind/files/elogind.init-r127
2 files changed, 28 insertions, 1 deletions
diff --git a/sys-auth/elogind/elogind-246.9.1.ebuild b/sys-auth/elogind/elogind-246.9.1-r1.ebuild
index afcc828ef599..1fe129445f40 100644
--- a/sys-auth/elogind/elogind-246.9.1.ebuild
+++ b/sys-auth/elogind/elogind-246.9.1-r1.ebuild
@@ -106,7 +106,7 @@ src_install() {
meson_src_install
- newinitd "${FILESDIR}"/${PN}.init ${PN}
+ newinitd "${FILESDIR}"/${PN}.init-r1 ${PN}
sed -e "s/@libdir@/$(get_libdir)/" "${FILESDIR}"/${PN}.conf.in > ${PN}.conf || die
newconfd ${PN}.conf ${PN}
diff --git a/sys-auth/elogind/files/elogind.init-r1 b/sys-auth/elogind/files/elogind.init-r1
new file mode 100644
index 000000000000..1cb5071c621e
--- /dev/null
+++ b/sys-auth/elogind/files/elogind.init-r1
@@ -0,0 +1,27 @@
+#!/sbin/openrc-run
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+depend() {
+ need dbus
+
+ # Make sure elogind is up before xdm starts any dm
+ before xdm
+
+ use logger
+}
+
+start() {
+ ebegin "Starting elogind"
+
+ start-stop-daemon --start --quiet \
+ --pidfile "${ELOGIND_PIDFILE}" \
+ --exec "${ELOGIND_EXEC}" -- --daemon
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping elogind"
+ start-stop-daemon --stop --quiet --pidfile "${ELOGIND_PIDFILE}"
+ eend $?
+}