summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/libfprint/files')
-rw-r--r--sys-auth/libfprint/files/libfprint-0.5.0-automake-1.13.patch24
-rw-r--r--sys-auth/libfprint/files/libfprint-0.5.0-support-147e_2020.patch48
2 files changed, 72 insertions, 0 deletions
diff --git a/sys-auth/libfprint/files/libfprint-0.5.0-automake-1.13.patch b/sys-auth/libfprint/files/libfprint-0.5.0-automake-1.13.patch
new file mode 100644
index 000000000000..e82082ab6d6a
--- /dev/null
+++ b/sys-auth/libfprint/files/libfprint-0.5.0-automake-1.13.patch
@@ -0,0 +1,24 @@
+From 43eca622cd49b58c87157e1ff1a2fcfdfba0934e Mon Sep 17 00:00:00 2001
+From: Vasily Khoruzhick <anarsoul@gmail.com>
+Date: Sun, 13 Jan 2013 13:42:13 +0000
+Subject: configure.ac: Use AC_CONFIG_HEADERS
+
+AM_CONFIG_HEADER is obsolete, use AC_CONFIG_HEADERS instead of it.
+
+https://bugs.freedesktop.org/show_bug.cgi?id=59320
+---
+diff --git a/configure.ac b/configure.ac
+index 6737256..978ef0d 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -2,7 +2,7 @@ AC_INIT([libfprint], [0.5.0])
+ AM_INIT_AUTOMAKE([1.11 no-dist-gzip dist-xz check-news])
+ AC_CONFIG_MACRO_DIR([m4])
+ AC_CONFIG_SRCDIR([libfprint/core.c])
+-AM_CONFIG_HEADER([config.h])
++AC_CONFIG_HEADERS([config.h])
+
+ # Enable silent build when available (Automake 1.11)
+ m4_ifdef([AM_SILENT_RULES],[AM_SILENT_RULES([yes])])
+--
+cgit v0.9.0.2-2-gbebe
diff --git a/sys-auth/libfprint/files/libfprint-0.5.0-support-147e_2020.patch b/sys-auth/libfprint/files/libfprint-0.5.0-support-147e_2020.patch
new file mode 100644
index 000000000000..98f72aed5a0d
--- /dev/null
+++ b/sys-auth/libfprint/files/libfprint-0.5.0-support-147e_2020.patch
@@ -0,0 +1,48 @@
+From 3b3679c900f6739f7067f8d720e15d548bb39be9 Mon Sep 17 00:00:00 2001
+From: Vasily Khoruzhick <anarsoul@gmail.com>
+Date: Sun, 13 Jan 2013 13:43:38 +0000
+Subject: upeke2: Add support for 147e:2020 ID
+
+https://bugs.freedesktop.org/show_bug.cgi?id=59320
+---
+diff --git a/libfprint/drivers/upeke2.c b/libfprint/drivers/upeke2.c
+index ed8f43d..a7db54d 100644
+--- a/libfprint/drivers/upeke2.c
++++ b/libfprint/drivers/upeke2.c
+@@ -46,6 +46,11 @@
+ #define MSG_READ_BUF_SIZE 0x40
+ #define MAX_DATA_IN_READ_BUF (MSG_READ_BUF_SIZE - 9)
+
++enum {
++ UPEKE2_2016,
++ UPEKE2_2020,
++};
++
+ struct upeke2_dev {
+ gboolean enroll_passed;
+ gboolean first_verify_iteration;
+@@ -848,8 +853,10 @@ static struct fpi_ssm *deinitsm_new(struct fp_dev *dev)
+
+ static int discover(struct libusb_device_descriptor *dsc, uint32_t *devtype)
+ {
+- /* Revision 2 is what we're interested in */
+- if (dsc->bcdDevice == 2)
++ if (dsc->idProduct == 0x2016 && dsc->bcdDevice == 2)
++ return 1;
++
++ if (dsc->idProduct == 0x2020 && dsc->bcdDevice == 1)
+ return 1;
+
+ return 0;
+@@ -1453,7 +1460,8 @@ static int verify_stop(struct fp_dev *dev, gboolean iterating)
+ }
+
+ static const struct usb_id id_table[] = {
+- { .vendor = 0x147e, .product = 0x2016 },
++ { .vendor = 0x147e, .product = 0x2016, .driver_data = UPEKE2_2016 },
++ { .vendor = 0x147e, .product = 0x2020, .driver_data = UPEKE2_2020 },
+ { 0, 0, 0, }, /* terminating entry */
+ };
+
+--
+cgit v0.9.0.2-2-gbebe