summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/pam_abl/pam_abl-0.6.0.ebuild')
-rw-r--r--sys-auth/pam_abl/pam_abl-0.6.0.ebuild18
1 files changed, 5 insertions, 13 deletions
diff --git a/sys-auth/pam_abl/pam_abl-0.6.0.ebuild b/sys-auth/pam_abl/pam_abl-0.6.0.ebuild
index 450c5c2e55b7..d1dafd1016f5 100644
--- a/sys-auth/pam_abl/pam_abl-0.6.0.ebuild
+++ b/sys-auth/pam_abl/pam_abl-0.6.0.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
MY_PN="${PN/_/-}"
MY_P="${MY_PN}-${PV}"
-inherit flag-o-matic pam cmake-utils db-use multilib
+inherit cmake db-use pam
DESCRIPTION="PAM module for blacklisting hosts and users repeatedly failed authentication"
HOMEPAGE="http://pam-abl.sourceforge.net/"
@@ -15,7 +15,6 @@ SRC_URI="mirror://sourceforge/${MY_PN}/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
DEPEND=">=sys-libs/pam-0.78-r2
>=sys-libs/db-4.2.52_p2:="
@@ -31,20 +30,13 @@ src_configure() {
-DDB_LINK_DIR=/usr/$(get_libdir)
-DDB_LIBRARY=$(db_libname)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
dodir $(getpam_mod_dir)
mv "${D}"/usr/lib/security/*.so "${D}"/"$(getpam_mod_dir)" || die
dodoc doc/*.txt README
}
-
-pkg_preinst() {
- if has_version "~${CATEGORY}/${PN}-0.5.0" ; then
- ewarn "Note: the 0.5.0 release named the module 'pam-abl.so' by accident; this version"
- ewarn "fixes that and uses 'pam_abl.so' again. Please update your config files."
- fi
-}