summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/pam_krb5/pam_krb5-4.10.ebuild')
-rw-r--r--sys-auth/pam_krb5/pam_krb5-4.10.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-auth/pam_krb5/pam_krb5-4.10.ebuild b/sys-auth/pam_krb5/pam_krb5-4.10.ebuild
new file mode 100644
index 000000000000..ec0f6ce19076
--- /dev/null
+++ b/sys-auth/pam_krb5/pam_krb5-4.10.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib
+
+DESCRIPTION="Kerberos V PAM Authentication Module"
+HOMEPAGE="https://www.eyrie.org/~eagle/software/pam-krb5/"
+SRC_URI="https://archives.eyrie.org/software/kerberos/pam-krb5-${PV}.tar.gz"
+
+LICENSE="|| ( BSD-2 GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE=""
+# tests fail without a /etc/krb5.conf
+RESTRICT="test"
+
+DEPEND="virtual/krb5
+ virtual/libcrypt:=
+ sys-libs/pam"
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${P/_/-}"
+
+src_configure() {
+ econf \
+ --libdir=/$(get_libdir)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc NEWS README TODO
+
+ rm "${D}/$(get_libdir)/security/pam_krb5.la"
+}