summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/pam_p11/pam_p11-0.3.1.ebuild')
-rw-r--r--sys-auth/pam_p11/pam_p11-0.3.1.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/sys-auth/pam_p11/pam_p11-0.3.1.ebuild b/sys-auth/pam_p11/pam_p11-0.3.1.ebuild
index b812b0b6f4e0..59c7cba7ce6d 100644
--- a/sys-auth/pam_p11/pam_p11-0.3.1.ebuild
+++ b/sys-auth/pam_p11/pam_p11-0.3.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools pam
+inherit autotools flag-o-matic pam
DESCRIPTION="PAM module for authenticating against PKCS#11 tokens"
HOMEPAGE="https://github.com/opensc/pam_p11/wiki"
@@ -21,6 +21,9 @@ DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
src_configure() {
+ # Ugly way to work around deprecated declarations in openssl-3
+ append-cflags -Wno-error=deprecated-declarations
+
econf --with-pamdir="$(getpam_mod_dir)"
}