summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/pam_u2f/pam_u2f-1.1.0.ebuild')
-rw-r--r--sys-auth/pam_u2f/pam_u2f-1.1.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-auth/pam_u2f/pam_u2f-1.1.0.ebuild b/sys-auth/pam_u2f/pam_u2f-1.1.0.ebuild
new file mode 100644
index 000000000000..6d719d8985b6
--- /dev/null
+++ b/sys-auth/pam_u2f/pam_u2f-1.1.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic pam
+
+DESCRIPTION="PAM module for FIDO2 and U2F keys"
+HOMEPAGE="https://github.com/Yubico/pam-u2f"
+SRC_URI="https://developers.yubico.com/${PN/_/-}/Releases/${P}.tar.gz"
+
+LICENSE="BSD ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug libressl"
+
+DEPEND="
+ dev-libs/libfido2:0=
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ sys-libs/pam"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}/${PN}-1.0.2-fix-Makefile.patch" )
+
+src_prepare() {
+ default
+ use debug || append-cppflags -UDEBUG_PAM -UPAM_DEBUG
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-pam-dir=$(getpam_mod_dir)
+}