summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/pam_u2f')
-rw-r--r--sys-auth/pam_u2f/Manifest1
-rw-r--r--sys-auth/pam_u2f/metadata.xml5
-rw-r--r--sys-auth/pam_u2f/pam_u2f-1.0.6.ebuild35
3 files changed, 40 insertions, 1 deletions
diff --git a/sys-auth/pam_u2f/Manifest b/sys-auth/pam_u2f/Manifest
index ddd0395277d8..d09bbb2ded85 100644
--- a/sys-auth/pam_u2f/Manifest
+++ b/sys-auth/pam_u2f/Manifest
@@ -1 +1,2 @@
DIST pam_u2f-1.0.4.tar.gz 349114 BLAKE2B 50811fe8b0076ff36af030e080593161a1f676f05d5eb970a50ea7092bac5bfe1832370d12b730be8422f7f42677ff950d5b3e932a6087a1698a4acba267c9d5 SHA512 324d1a1172eae567372f95971d9ee6bb237b47758b89c083f3cfb11275c4b0c22c4cf02a51380451f88d372dd6aaa415bdb671a43a7444062fbf8f50b658f087
+DIST pam_u2f-1.0.6.tar.gz 375181 BLAKE2B eac1457cbfd7951fd617ea0cff4220d6e5fe6f3e33cbc960024a28a1ca09f376fced27afa8e5a23dc5bab1881c226497c41fea7041dd891a36e1be7ba18c09f3 SHA512 e169d3d251a132213c04570099164aee0cdcea4bca233432f13af47b2cc5e420e14b3fb6dcde20cb8f77f9ed677459bd641aa3f9c1da65c88cd7490e26ab25e3
diff --git a/sys-auth/pam_u2f/metadata.xml b/sys-auth/pam_u2f/metadata.xml
index cf254588f2ee..29f1229e1201 100644
--- a/sys-auth/pam_u2f/metadata.xml
+++ b/sys-auth/pam_u2f/metadata.xml
@@ -6,10 +6,13 @@
<name>Göktürk Yüksek</name>
</maintainer>
<use>
- <flag name="debug">
+ <flag name="debug" restrict="&lt;sys-auth/pam_u2f-1.0.6">
Enable debug messages using the pam logging macros.
(Note: these will be visible on stdout for terminal logins).
</flag>
+ <flag name="debug">
+ Enable debug messages using the pam logging macros.
+ </flag>
</use>
<upstream>
<remote-id type="github">Yubico/pam-u2f</remote-id>
diff --git a/sys-auth/pam_u2f/pam_u2f-1.0.6.ebuild b/sys-auth/pam_u2f/pam_u2f-1.0.6.ebuild
new file mode 100644
index 000000000000..c90ab12d94dd
--- /dev/null
+++ b/sys-auth/pam_u2f/pam_u2f-1.0.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools flag-o-matic pam
+
+DESCRIPTION="Library for authenticating against PAM with a Yubikey"
+HOMEPAGE="https://github.com/Yubico/pam-u2f"
+SRC_URI="https://developers.yubico.com/${PN/_/-}/Releases/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="
+ app-crypt/libu2f-host
+ app-crypt/libu2f-server:=
+ virtual/pam"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}/${PN}-1.0.2-fix-Makefile.patch" )
+
+src_prepare() {
+ default
+ use debug || append-cppflags -UDEBUG_PAM -UPAM_DEBUG
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-pam-dir=$(getpam_mod_dir)
+}