summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-auth/polkit-qt/polkit-qt-0.112.0_p20160416-r2.ebuild')
-rw-r--r--sys-auth/polkit-qt/polkit-qt-0.112.0_p20160416-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-auth/polkit-qt/polkit-qt-0.112.0_p20160416-r2.ebuild b/sys-auth/polkit-qt/polkit-qt-0.112.0_p20160416-r2.ebuild
new file mode 100644
index 000000000000..e909e08a5bfd
--- /dev/null
+++ b/sys-auth/polkit-qt/polkit-qt-0.112.0_p20160416-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_P="${P/qt/qt-1}"
+inherit cmake-utils
+
+DESCRIPTION="PolicyKit Qt API wrapper library"
+HOMEPAGE="https://api.kde.org/kdesupport-api/polkit-qt-1-apidocs/"
+SRC_URI="https://dev.gentoo.org/~kensington/distfiles/${MY_P}.tar.xz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="debug examples"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ >=sys-auth/polkit-0.103
+ examples? ( dev-qt/qtxml:5 )
+"
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS README README.porting TODO )
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_EXAMPLES=$(usex examples)
+ -DUSE_QT4=OFF
+ -DUSE_QT5=ON
+ )
+
+ cmake-utils_src_configure
+}